Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230601 - Feature Request: Autoconf 2.61
Summary: Feature Request: Autoconf 2.61
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: autoconf
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 18:34 UTC by Debarshi Ray
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.61-9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-14 06:19:19 UTC


Attachments (Terms of Use)

Description Debarshi Ray 2007-03-01 18:34:12 UTC
Description of problem:

Since the release of Autoconf 2.59, a number of portability  related problems
have been fixed in Autoconf. Distributing a configure infrastructure made using
Autoconf 2.59 is telling the user to solve these portability issues themselves.
Moreover as a developer of GNU Parted I have to use 2.61 instead of anything
older since  Parted's configure scripts are generated using Autoconf 2.61
because we would not like our users to face any problem.


Version-Release number of selected component (if applicable):

Autoconf 2.59.


Additional info:

From this link: http://www.gnu.org/software/autoconf/#TOCintroduction it seems
that GNU M4 1.7 or later would be a dependency. Currently Fedora has  GNU 1.4.5.

Comment 1 Karsten Hopp 2007-03-02 12:56:10 UTC
adding the m4 maintainer for comments about the m4 update...

Vitezslav, is a m4 update possible without breaking anything ?

Comment 2 Debarshi Ray 2007-03-07 09:22:33 UTC
First of all sorry for saying "that GNU M4 1.7 or later would be a dependency".
It should  be version 1.4.7. I have been using GNU M4 1.4.8 compiled from source
for the last few dayss, and am yet to notice any breakage.

Comment 3 Vitezslav Crhonek 2007-03-20 12:39:45 UTC
Hello,
updating m4 seems OK to me and I'll update it.

Comment 4 Vitezslav Crhonek 2007-03-21 08:17:31 UTC
M4 updated to 1.4.8 in FC-6.

Comment 5 Ville Skyttä 2007-04-11 19:49:22 UTC
(In reply to comment #4)
> M4 updated to 1.4.8 in FC-6.

I don't see any m4 versions >= 1.4.5 for FC-6 in updates or updates-testing. 
Was this meant to say FC-7?

Comment 6 Vitezslav Crhonek 2007-04-16 15:16:51 UTC
Sorry, I only built it and forgot add update... Thanks for giving a notice!

Comment 7 Debarshi Ray 2007-05-19 04:15:05 UTC
Since Rawhide already has Autoconf 2.61, can this bug be closed?  


Note You need to log in before you can comment on or make changes to this bug.