Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230595 - HP500 notebook synoptics touchpad
Summary: HP500 notebook synoptics touchpad
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
: 230603 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 18:17 UTC by Alexandru Ciobanu
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.6.20-1.2952.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-31 14:20:06 UTC


Attachments (Terms of Use)
i8042.c patch (deleted)
2007-03-01 18:17 UTC, Alexandru Ciobanu
no flags Details | Diff

Description Alexandru Ciobanu 2007-03-01 18:17:08 UTC
Description of problem:
Synoptics touchpad is not recognized.
Version-Release number of selected component (if applicable):
2.6.19-1.2895.fc6, 2.6.19-1.2911.fc6, 2.6.20-1.2947.fc7

How reproducible:
Always

Steps to Reproduce:
1. Boot any of these kernels.

  
Actual results:
Synoptics touchpad not recognized.

Expected results:
Synoptics touchpad automagically recognition.

Additional info:

Comment 1 Alexandru Ciobanu 2007-03-01 18:17:08 UTC
Created attachment 149032 [details]
i8042.c patch

Comment 2 Will Woods 2007-03-01 18:50:11 UTC
*** Bug 230603 has been marked as a duplicate of this bug. ***

Comment 3 Alexandru Ciobanu 2007-03-01 19:02:49 UTC
Touchpad is not automagically recognized on HP500 notebook.

Comment 4 Chuck Ebbert 2007-03-30 22:15:59 UTC
A test kernel is at http://people.redhat.com/cebbert

Please test and report your results.

Comment 5 Alexandru Ciobanu 2007-03-30 23:38:24 UTC
Tested kernel-2.6.20-1.2938.fc6.i686.rpm.
The issue prevails.

Comment 6 Dmitry Torokhov 2007-05-30 14:05:59 UTC
I think the following commit will fix the issue:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
2.6.git;a=commit;h=d2ada5597d33a9108acb2caf912f85cbc9caab1e

Comment 7 Chuck Ebbert 2007-05-30 18:06:46 UTC
(In reply to comment #6)
> I think the following commit will fix the issue:
> 
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
> 2.6.git;a=commit;h=d2ada5597d33a9108acb2caf912f85cbc9caab1e

Patch is in kernel 1.2952, in testing, should be released today.

Comment 8 Alexandru Ciobanu 2007-05-31 13:12:33 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > I think the following commit will fix the issue:
> > 
> > http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
> > 2.6.git;a=commit;h=d2ada5597d33a9108acb2caf912f85cbc9caab1e
> 
> Patch is in kernel 1.2952, in testing, should be released today.

Dmitry's commit solved the issue. Both vanilla and 1.2952 automagically
recognize the touchpad.



Note You need to log in before you can comment on or make changes to this bug.