Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230584 - face changes aren't picked up
Summary: face changes aren't picked up
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 17:14 UTC by Bill Nottingham
Modified: 2014-03-17 03:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-10 12:29:22 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2007-03-01 17:14:43 UTC
Description of problem:

GDM still shows the generic icon, instead of the face selected.

Version-Release number of selected component (if applicable):

gdm-2.17.8-1.fc7

How reproducible:

Every time

Steps to Reproduce:
1. Go to 'About Me'
2. Select a random face
3. Log out
  
Actual results:

Still get generic white person logo.

Expected results:

A baseball. Or a chess piece. Or a duck!

Additional info:

Restarting gdm entirely (telinit 3 ; telinit 5) doesn't help.

Comment 1 Bill Nottingham 2007-03-02 20:47:47 UTC
As a data point, I tried changing the default face in gdmsetup, and still got
the generic icon.

Comment 2 Ray Strode [halfline] 2007-04-03 14:56:42 UTC
what is the output of ls -ld ~ ~/.face ?

Comment 3 Bill Nottingham 2007-04-06 05:26:35 UTC
[notting@nostromo: ~]$ ls -ld ~ ~/.face 
drwxr-xr-x 154 notting notting 77824 2007-04-06 01:21 /home/notting
-rw-rw-r--   1 notting notting  3034 2007-04-06 01:24 /home/notting/.face


Comment 4 David Zeuthen 2007-04-15 02:16:58 UTC
The face needs to have permission 755 IIRC - does that work?

Comment 5 David Zeuthen 2007-04-15 02:17:56 UTC
This, btw, looks like a dup of bug 236393.

Comment 6 Bill Nottingham 2007-04-16 17:51:35 UTC
755? Not 644???

Comment 7 Bill Nottingham 2007-04-16 19:54:12 UTC
755 works. So this bug should either be against:

1) gdm, for requiring 755 (when 0644 should be fine)

or:

2) gnome-about-me - for writing them as 0644 by default

Comment 8 David Zeuthen 2007-04-16 20:09:08 UTC
(In reply to comment #7)
> 755 works. So this bug should either be against:
> 
> 1) gdm, for requiring 755 (when 0644 should be fine)

This, IIRC, is a feature to require consent from the user that it's fine to
display his face which originates from a personal file in his home directory.
ICBW, and yes, I do think this is a weird security requirement.

Also, f-u-s-a and the screensaver do the same check IIRC.

> 2) gnome-about-me - for writing them as 0644 by default

This is what we should be fixing.

Comment 9 Bill Nottingham 2007-04-16 20:15:14 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > 755 works. So this bug should either be against:
> > 
> > 1) gdm, for requiring 755 (when 0644 should be fine)
> 
> This, IIRC, is a feature to require consent from the user that it's fine to
> display his face which originates from a personal file in his home directory.
> ICBW, and yes, I do think this is a weird security requirement.

Is this documented somewhere?

(This seems like a better job for selinux or similar.)

Comment 10 David Zeuthen 2007-04-16 20:20:38 UTC
(In reply to comment #9)
> Is this documented somewhere?

Don't know; I remember googling for it a while back and found some fragments;
but I can't find this right now.

> (This seems like a better job for selinux or similar.)

No, it's completely broken to retrieve the users face from the home directory
because it means you can't see other users faces from f-u-s-a. It should
probably originate from the same place as the _rest_ of you account details. 

Probably libuser should provide get/set functionality. Another option is to have
a system-wide D-Bus service. Yada yada yada.


Comment 11 Matthias Clasen 2007-05-10 12:29:22 UTC
gnome-about-me has been fixed to use 755 now. Time to close this, I think.

Comment 12 Valent Turkovic 2007-05-10 14:01:54 UTC
Hi,
IMHO the GDM theme on Fedora 7 test 3 was much more user-friendly and
looked nicer than one I see in Fedora 7 test 4. The theme hasn't
changed but the icon for "face browser" had. Not beside user name
there is some strange icon with a question mark on the face which
looks odious to me.

It doesn't look inviting, and doesn't give me the welcome feeling that
a login page should be about.

And comments? Or is it just me? :)


Note You need to log in before you can comment on or make changes to this bug.