Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230580 - odd output when querying based on arch
Summary: odd output when querying based on arch
Keywords:
Status: CLOSED DUPLICATE of bug 124016
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 16:59 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-11 14:28:30 UTC


Attachments (Terms of Use)

Description Jeremy Katz 2007-03-01 16:59:53 UTC
Querying for a package by arch can lead to odd (lack of) output in some cases.

Easiest to show with an example:
[katzj@erebor creator]$ rpm -q bash
bash-0:3.2-9.fc7.x86_64
[katzj@erebor creator]$ rpm -q bash.x86_64
bash-0:3.2-9.fc7.x86_64
[katzj@erebor creator]$ rpm -q bash.i386
[katzj@erebor creator]$ rpm -q foo
package foo is not installed
[katzj@erebor creator]$ rpm -q foo.i386
package foo.i386 is not installed


I'd expect the query for bash.i386 to say that it's not installed.

Comment 1 Michal Jaegermann 2007-03-02 04:00:34 UTC
That goes somewhat deeper.  Watch this:
$ rpm -q bash ; echo $?
bash-3.2-9.fc7
0
$rpm -q bash.x86_64 ; echo $?
bash-3.2-9.fc7
0
$ rpm -q foo ; echo $?
package foo is not installed
1
$ rpm -q foo.i386 ; echo $?
package foo.i386 is not installed
1
$ rpm -q bash.i386 ; echo $?
0

Clearly your rpm is configured in some non-default way if
it responds with 'bash-0:3.2-9.fc7.x86_64' but that is not the issue.

Comment 2 Jeff Johnson 2007-03-08 13:06:45 UTC
This is a dupe of another bug report (by D. Hugh Radimier iirc).

UPSTREAM

Comment 3 Panu Matilainen 2007-06-11 14:28:30 UTC

*** This bug has been marked as a duplicate of 124016 ***


Note You need to log in before you can comment on or make changes to this bug.