Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230579 - getfacl exit code changed between FC6 and devel
Summary: getfacl exit code changed between FC6 and devel
Keywords:
Status: CLOSED DUPLICATE of bug 232884
Alias: None
Product: Fedora
Classification: Fedora
Component: acl
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 16:47 UTC by Tim Waugh
Modified: 2015-02-01 22:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-11 09:54:02 UTC
wtogami: fedora-cvs+


Attachments (Terms of Use)

Description Tim Waugh 2007-03-01 16:47:08 UTC
Description of problem:
In FC6, 'touch a; getfacl a' gave an exit-code of 0.  In devel
(acl-2.2.39-3.fc7) it gives an exit-code of 1.  The coreutils test suite checks
the exit code and determines than an error has occurred, and fails the ACL tests.

Can we get some documentation on what the expected meaning of the exit code for
getfacl and setfacl is, as well as a bit of consistency?  For instance, if it's
an error exit code (as seems to be the case from the source code) -- what was
the error in 'touch a; getfacl a'?

Version-Release number of selected component (if applicable):
acl-2.2.39-3.fc7

How reproducible:
100%

Steps to Reproduce:
1.touch a
2.getfacl a
3.echo $?
  
Actual results:
1

Expected results:
0

Additional info:
No documentation about the exit code in the man page.

Comment 1 Jiri Moskovcak 2007-07-09 12:38:49 UTC
Package Change Request
======================
Package Name: acl
Updated Fedora Owners: jmoskovc@redhat.com

Comment 2 Jiri Moskovcak 2007-07-11 09:54:02 UTC

*** This bug has been marked as a duplicate of 232884 ***


Note You need to log in before you can comment on or make changes to this bug.