Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230568 - Package Updater Dump Information
Summary: Package Updater Dump Information
Keywords:
Status: CLOSED DUPLICATE of bug 230236
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 16:25 UTC by Al Cranford
Modified: 2014-01-21 22:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-16 15:00:38 UTC


Attachments (Terms of Use)
Package Updater dump information upon exception error (deleted)
2007-03-01 16:25 UTC, Al Cranford
no flags Details

Description Al Cranford 2007-03-01 16:25:59 UTC
Description of problem:
Once again I am experiencing Update problems with FC6.  I get the following
information upon failure:

Component: Software Updater	
Summary: TBccefa5c9 yumRepo.py:426:__get:RepoError: failure:
nspr-devel-4.6.5-0.6.0.fc6.i386.rpm from updates: [Errno 256] No more mirrors to
try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 433, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 559, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 324, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 150, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 760, in
downloadHeader
    cache=repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 454, in getHeader
    cache=cache,
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 426, in __get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
RepoError: failure: nspr-devel-4.6.5-0.6.0.fc6.i386.rpm from updates: [Errno
256] No more mirrors to try.

Local variables in innermost frame:
e: [Errno 256] No more mirrors to try.
start: 440
url: None
text: None
self: updates
cache: True
reget: None
relative: nspr-devel-4.6.5-0.6.0.fc6.i386.rpm
headers: ()
checkfunc: (<bound method PackageUpdater.verifyHeader of
<__main__.PackageUpdater object at 0x9f6784c>>,
(<yum.sqlitesack.YumAvailablePackageSqlite object at 0xb3f77cc>, 1), {})
copy_local: 1
end: 10829
local: //var/cache/yum/updates/headers/nspr-devel-4.6.5-0.6.0.fc6.i386.hdr


Version-Release number of selected component (if applicable):


How reproducible:
2 out of 2 times

Steps to Reproduce:
1. View Updates
2. Apply Updates
3.
  
Actual results:


Expected results:


Additional info:
I have tried running update via terminal and "yum update" but this also fails.
This time the problem seems to be with the
../i386/audit-libs-1.4.2-2.fc6.i386.rpm Header not being complete.  After
checking all mirros my final error states:
Error: failure: audit-libs-1.4.2-2.fc6.i386.rpm from updates [Errno 256] No more
mirrors to try.

Comment 1 Al Cranford 2007-03-01 16:25:59 UTC
Created attachment 149023 [details]
Package Updater dump information upon exception error

Comment 2 Adrien Bustany 2007-04-12 10:02:01 UTC
This bug is a duplicate of 230236 (and is not a bug, just a misconception in pup)

Comment 3 Jeremy Katz 2007-04-16 15:00:38 UTC

*** This bug has been marked as a duplicate of 230236 ***


Note You need to log in before you can comment on or make changes to this bug.