Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230565 - Worlwide mirrorlist broken
Summary: Worlwide mirrorlist broken
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 16:09 UTC by Milan Kerslager
Modified: 2014-01-21 22:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-01 16:39:08 UTC


Attachments (Terms of Use)

Description Milan Kerslager 2007-03-01 16:09:55 UTC
When trying to get mirrorlist from
http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=i386

I've got:
# repo = rawhide country = CZ arch = i386 
http://sunsite.mff.cuni.cz/pub/fedora/development/i386/os/
# No results found for country: CZ
# Defaulting to global
http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/core/development/i386/os/
http://sunsite.mff.cuni.cz/pub/fedora/development/i386/os/
http://download.fedoraproject.org/pub/fedora/linux/core/development/i386/os/
...

It seems that even tehere are mirrors in the Czech republic, global mirrors are
printed. The same is for Fedora Core 6.

Comment 1 Mike McGrath 2007-03-01 16:33:12 UTC
This is intended behavior.  The issue is that there's only one valid mirror for
country CZ.  People had been complaining about similar issues so now the script
returns global list when the mirror list is small.  The mirror lists the script
pull from are listed here:

http://fedora.redhat.com/Download/mirrors/fedora-core-rawhide

(For rawhide anyway)  If this is an issue for you, your best bet is to not use
the mirror list and just contact your mirror directly.


Note You need to log in before you can comment on or make changes to this bug.