Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230538 - call trace kobject_add
Summary: call trace kobject_add
Keywords:
Status: CLOSED DUPLICATE of bug 212109
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 12:02 UTC by Neal Becker
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-19 20:26:02 UTC


Attachments (Terms of Use)

Description Neal Becker 2007-03-01 12:02:04 UTC
Description of problem:

Mar  1 05:56:19 localhost kernel: kobject_add failed for vcs1 with -EEXIST, 
don't try to register things with the same name in the same directory.
Mar  1 05:56:19 localhost kernel: 
Mar  1 05:56:19 localhost kernel: Call Trace:
Mar  1 05:56:19 localhost kernel:  [<ffffffff8026999a>] show_trace+0x34/0x47
Mar  1 05:56:19 localhost kernel:  [<ffffffff802699bf>] dump_stack+0x12/0x17
Mar  1 05:56:19 localhost kernel:  [<ffffffff80343e82>] 
kobject_add+0x174/0x19f
Mar  1 05:56:19 localhost kernel:  [<ffffffff803af888>] 
class_device_add+0xb2/0x464
Mar  1 05:56:19 localhost kernel:  [<ffffffff803afd27>] 
class_device_create+0xdb/0x10a
Mar  1 05:56:19 localhost kernel:  [<ffffffff80394132>] 
vcs_make_sysfs+0x2d/0x5b
Mar  1 05:56:19 localhost kernel:  [<ffffffff803995d5>] con_open+0x7c/0x8b
Mar  1 05:56:19 localhost kernel:  [<ffffffff80391807>] tty_open+0x1ad/0x36c
Mar  1 05:56:19 localhost kernel:  [<ffffffff8024792f>] 
chrdev_open+0x149/0x198
Mar  1 05:56:19 localhost kernel:  [<ffffffff8021e831>] 
__dentry_open+0xd9/0x1df
Mar  1 05:56:19 localhost kernel:  [<ffffffff80227b55>] do_filp_open+0x2a/0x38
Mar  1 05:56:19 localhost kernel:  [<ffffffff80219a1d>] do_sys_open+0x44/0xbe
Mar  1 05:56:19 localhost kernel:  [<ffffffff8025c29c>] tracesys+0xdc/0xf0
Mar  1 05:56:19 localhost kernel:  [<0000003d932bf480>]Mar  1 05:56:19 
localhost kernel: kobject_add failed for vcs1 with -EEXIST, don't try to 
register things with the same name in the same directory.
Mar  1 05:56:19 localhost kernel: 
Mar  1 05:56:19 localhost kernel: Call Trace:
Mar  1 05:56:19 localhost kernel:  [<ffffffff8026999a>] show_trace+0x34/0x47
Mar  1 05:56:19 localhost kernel:  [<ffffffff802699bf>] dump_stack+0x12/0x17
Mar  1 05:56:19 localhost kernel:  [<ffffffff80343e82>] 
kobject_add+0x174/0x19f
Mar  1 05:56:19 localhost kernel:  [<ffffffff803af888>] 
class_device_add+0xb2/0x464
Mar  1 05:56:19 localhost kernel:  [<ffffffff803afd27>] 
class_device_create+0xdb/0x10a
Mar  1 05:56:19 localhost kernel:  [<ffffffff80394132>] 
vcs_make_sysfs+0x2d/0x5b
Mar  1 05:56:19 localhost kernel:  [<ffffffff803995d5>] con_open+0x7c/0x8b
Mar  1 05:56:19 localhost kernel:  [<ffffffff80391807>] tty_open+0x1ad/0x36c
Mar  1 05:56:19 localhost kernel:  [<ffffffff8024792f>] 
chrdev_open+0x149/0x198
Mar  1 05:56:19 localhost kernel:  [<ffffffff8021e831>] 
__dentry_open+0xd9/0x1df
Mar  1 05:56:19 localhost kernel:  [<ffffffff80227b55>] do_filp_open+0x2a/0x38
Mar  1 05:56:19 localhost kernel:  [<ffffffff80219a1d>] do_sys_open+0x44/0xbe
Mar  1 05:56:19 localhost kernel:  [<ffffffff8025c29c>] tracesys+0xdc/0xf0
Mar  1 05:56:19 localhost kernel:  [<0000003d932bf480>]
Version-Release number of selected component (if applicable):

kernel-2.6.19-1.2911.fc6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dave Jones 2007-03-19 20:26:02 UTC

*** This bug has been marked as a duplicate of 212109 ***


Note You need to log in before you can comment on or make changes to this bug.