Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230528 - openoffice.org depends on "java development", i.e. xerces-j2, xalan-j2
Summary: openoffice.org depends on "java development", i.e. xerces-j2, xalan-j2
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 09:15 UTC by Karl Lattimer
Modified: 2013-01-10 01:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-01 15:19:28 UTC


Attachments (Terms of Use)

Description Karl Lattimer 2007-03-01 09:15:26 UTC
Description of problem:
If you remove java development from the groups view it also uninstalls open office. 

How reproducible:
Last 3 times I tried it

Steps to Reproduce:
1. uncheck java development under development in groups view
2. click apply
  
Actual results:
Open office is uninstalled

Expected results:
Java development to be uninstalled and not to remove open office as a dependency

Additional info:
The packages within java development that open office depends on should be moved
to somewhere else within the groups view, possibly java runtime?

Comment 1 Caolan McNamara 2007-03-01 09:52:51 UTC
Requires: libgcj >= 4.0.0, bsh, hsqldb >= 1.80.1, xalan-j2, xerces-j2

and on autorequires we additionally need libjawt.so
rpm -q --whatprovides libjawt.so
libgcj

These are all correct requires. Looks like the problem is that xalan-j2 and
xerces-j2 and their dependancies are considered java development. OOo won't work
completely (xslt transform features) if they are removed. Similarly bsh is used
in the scripting environment to go alongside the basic editor to provide a
beanshell scripting UI so there's no bug here on the OOo side.


Comment 2 Jesse Keating 2007-03-01 15:19:28 UTC
The problem is that much of java is both runtime _and_ development.  The java
guys want these things listed in java development also.

I'll ask them to re-review the java groupings within comps, but this may be an
unavoidable situation.


Note You need to log in before you can comment on or make changes to this bug.