Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230511 - Incorrect indenting in mixed lists
Summary: Incorrect indenting in mixed lists
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests
Version: devel
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dimitris Glezos
QA Contact: Karsten Wade
URL: http://fedoraproject.org/wiki/DocsPro...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-01 04:17 UTC by Karsten Wade
Modified: 2009-08-05 18:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-13 05:11:55 UTC


Attachments (Terms of Use)
screenshot that demonstrates the strange indenting problem I'm seeing. (deleted)
2007-03-01 04:17 UTC, Karsten Wade
no flags Details

Description Karsten Wade 2007-03-01 04:17:26 UTC
I am seeing strange indenting on pages all over the Wiki, all within various
types of bulleted or numbered lists:

http://fedoraproject.org/wiki/DocsProject/WorkFlow

I've attached a screenshot of the problem-in-action.  This is just an example
page, I've seen this on other pages, including:

http://fedoraproject.org/wiki/F7Test2/ReleaseNotes
http://fedoraproject.org/wiki/Docs/Drafts/ReleaseAnnouncements

Comment 1 Karsten Wade 2007-03-01 04:17:26 UTC
Created attachment 148988 [details]
screenshot that demonstrates the strange indenting problem I'm seeing.

Comment 2 Dimitris Glezos 2007-03-01 23:46:59 UTC
Wiki lists seem to have a problem right now. Dunno what's causing it, but I
noticed that most of them are caused by spaces at the start of a line.

BTW, the Infr Project uses the following page for the wiki tasks:

  http://fedoraproject.org/wiki/Infrastructure/WikiMigration

Comment 3 Karsten Wade 2007-03-02 00:30:19 UTC
Thanks, I see that page is tracking stuff now; I can stop filing bug reports if
you prefer. :)

I'm aware of the extra whitespace at the start of a line defining it as a
bullet, such as what happens when a table is started with whitespace:

 || foo ||
vs
|| foo ||

Some of the problems seem to be with mixed number/bullets, but I don't think
that is exclusively it.

It seems to be CSS because disabling styles for the page causes the bullets and
number to appear fine.

Comment 4 Dimitris Glezos 2007-03-02 01:20:46 UTC
I'll take a closer look to this in the following days along with many other
wiki-specific tweaks.

Since its a CSS-specific one (although I'm no CSS guru), I'll re-assign it to
myself to make sure I won't forget it. :-)

Comment 5 Dimitris Glezos 2007-03-02 14:33:45 UTC
OK, I think I've found the prob, its because I used a `list-style: none` instead
of putting the bullet in that tag.

I've sent Mike an email with a fix. Leaving open until testing.

Comment 6 Dimitris Glezos 2007-03-13 05:11:55 UTC
I think I got this fixed today.

I'm closing the bug. Please test and re-open/comment if you see anything strange.

Comment 7 eric@christensenplace.us 2009-08-05 18:43:11 UTC
Tickets move to docs-request so the fedora-websites component can be removed per request from Ricky.


Note You need to log in before you can comment on or make changes to this bug.