Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230477 - yum gives traceback after 'localupdate'
Summary: yum gives traceback after 'localupdate'
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 22:24 UTC by Michal Jaegermann
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-28 23:03:58 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2007-02-28 22:24:23 UTC
Description of problem:

An attempt to run 'yum localupdate *.rpm' on a directory full
of packages from the current rawhide update produces the following:

......
Resolving Dependencies
--> Running transaction check
Checking deps for net-snmp-libs.x86_64 1-5.4-8.fc7 - None
Checking deps for pango-devel.x86_64 0-1.16.0-1.fc7 - u
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 451, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 1104, in
_resolveDeps
    deps = self._mytsCheck()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 1082, in _mytsCheck
    ret.extend(self._checkUpdate(txmbr))
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 1265, in
_checkUpdate
    ret = self._checkInstall(txmbr)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 1234, in
_checkInstall
    dep = self._provideToPkg(req)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 1029, in
_provideToPkg
    for po in self.whatProvides(r, f, v):
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in whatProvides
    pkgs = self.pkgSack.searchProvides(name)
AttributeError: 'NoneType' object has no attribute 'searchProvides'

Version-Release number of selected component (if applicable):
yum-3.1.2-1.fc7

How reproducible:
In this particular situation seems to be consistent.

Comment 1 Jeremy Katz 2007-02-28 23:03:58 UTC
This is fixed already upstream and will be in 3.1.3 in the next day or two.


Note You need to log in before you can comment on or make changes to this bug.