Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230462 - RFE: Only reboot installation target machines when needed
Summary: RFE: Only reboot installation target machines when needed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ryan McCabe
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks: 230466
TreeView+ depends on / blocked
 
Reported: 2007-02-28 21:39 UTC by Rob Kenna
Modified: 2009-04-16 22:43 UTC (History)
4 users (show)

Fixed In Version: RHBA-2008-0407
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 15:46:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0407 normal SHIPPED_LIVE conga bug fix and enhancement update 2008-05-21 15:46:31 UTC

Description Rob Kenna 2007-02-28 21:39:51 UTC
When Conga builds the cluster, the nodes added to the cluster are rebooted.  If
this is not required for proper installation, then we should force the reboot

Comment 2 Stanko Kupcevic 2007-03-06 11:43:01 UTC
Reboot is required whenever kernel is in the chain of dependencies of rpms to
install during deployment. 

RHEL4: base cluster (cman-kernel, dlm-kernel) and shared storage (GFS-kernel)

RHEL5: shared storage (kmod-gfs, kmod-gfs-xen)


So, reboot can be avoided in the case of failover cluster (no shared storage)
deployment. 


Comment 3 Stanko Kupcevic 2007-03-06 11:46:05 UTC
So, reboot can be avoided in the case of deployment of RHEL5 failover cluster
(no shared storage). 

Comment 4 Ryan McCabe 2007-09-26 03:17:26 UTC
*** Bug 303261 has been marked as a duplicate of this bug. ***

Comment 7 Brian Brock 2008-05-15 00:42:49 UTC
bugfix seems to work and be present, nodes didn't reboot when unneccessary. 
Changing state to verified.

Comment 9 errata-xmlrpc 2008-05-21 15:46:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0407.html


Note You need to log in before you can comment on or make changes to this bug.