Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230423 - ptrace causing SIGSEGV in debugged process when sending SIGKILL to it.
Summary: ptrace causing SIGSEGV in debugged process when sending SIGKILL to it.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Roland McGrath
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 19:37 UTC by Kevin Van Brunt
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 2.6.20-1.2925.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-20 17:27:07 UTC


Attachments (Terms of Use)
A test c program that demonstrates the bug. (deleted)
2007-02-28 19:41 UTC, Kevin Van Brunt
no flags Details

Description Kevin Van Brunt 2007-02-28 19:37:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)

Description of problem:
I have written a small program to demonstrate this bug.  It causes ptrace to trace /bin/ls.  After the first waitpid, the parent sends a SIGKILL to ls and ls performs a segmentation fault.  /bin/ls is only used as an example.  Any traced process has the same problem.  I have traced xterm, firefox, and gnome-cd as well and seen the bug.

The code will be attached to this bug report.

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2911.fc6

How reproducible:
Always


Steps to Reproduce:
1. Compile and run the attached code.

Actual Results:
The message "GOT SIGSEGV" should appear because the traced program performs a segmentation fault.

Expected Results:
The traced program should not perform a segmentation fault and no message should appear.

Additional info:

Comment 1 Kevin Van Brunt 2007-02-28 19:41:19 UTC
Created attachment 148952 [details]
A test c program that demonstrates the bug.

Comment 2 Albert Cahalan 2007-03-07 04:31:25 UTC
A pure 2.6.20.1 kernel does not show the problem at all. I even tried adding
sched_yield in various places to see if scheduling order would affect things.

This is probably a utrace bug.


Comment 3 Roland McGrath 2007-03-19 23:03:55 UTC
I reproduced this on 2.6.19-1.2911.fc6 but not on 2.6.20-1.2925.fc6.
Please try the latest fc6 update kernel and verify that the problem is gone for you.

Comment 4 Kevin Van Brunt 2007-03-20 17:20:41 UTC
It looks to be fixed in 2.6.20-1.2925.fc6.


Note You need to log in before you can comment on or make changes to this bug.