Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230378 - Kernel 2.6.18-8 (RHEL5 RC1) locks up when issuing >20 counts of 2K blocks to an sg device, i.e., tape drive or cdrom
Summary: Kernel 2.6.18-8 (RHEL5 RC1) locks up when issuing >20 counts of 2K blocks to ...
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 17:42 UTC by Quang Ngo
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-28 17:52:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Quang Ngo 2007-02-28 17:42:04 UTC
Description of problem:
Kernel 2.6.18-8 (RHEL5 RC1) locks up when issuing >20 counts of 2K blocks to an 
sg device, i.e., tape drive or cdrom.

Version-Release number of selected component (if applicable):
Kernel 2.6.18-8 (RHEL5 RC1)

How reproducible:
Simply write >20 counts of 2K blocks to a sg device such as a tape drive or 
CD/DVD drive.

Steps to Reproduce:
1. Download the sg3 utility package (sg3_utils-1.20.tgz) from 
http://sg.torque.net/sg/p/
2. Compile it
3. Hook up a tape drive
4. Modprobe the sg module
5. Run: sg_write_buffer --length=45056 /dev/sg0   where sg0 is the tape drive

Actual results:
The system locks up instantly; you won't be able to move the mouse.

Expected results:
System lockup

Additional info:
See attached C program.

Comment 1 Linda Wang 2007-02-28 17:52:38 UTC

*** This bug has been marked as a duplicate of 230377 ***


Note You need to log in before you can comment on or make changes to this bug.