Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230334 - Unable to print to the network printer
Summary: Unable to print to the network printer
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 6
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 13:33 UTC by Vaclav "sHINOBI" Misek
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-28 15:01:59 UTC


Attachments (Terms of Use)
cups error log (deleted)
2007-02-28 13:33 UTC, Vaclav "sHINOBI" Misek
no flags Details
requested tcpdump (deleted)
2007-02-28 14:37 UTC, Vaclav "sHINOBI" Misek
no flags Details

Description Vaclav "sHINOBI" Misek 2007-02-28 13:33:49 UTC
Description of problem:
I'm unable to print to the HP Color Laserjet 3550 (network printer)

Version-Release number of selected component (if applicable):
cups-1.2.8-2.fc6

How reproducible:
always

Steps to Reproduce:
1. I try to print any document including CUPS test page
2.
3.
  
Actual results:
nothing happens, the data aren't send to printer

Expected results:


Additional info:
foomatic-3.0.2-39.4.fc6
hplip-1.6.12-1.fc6

For testing purposes I tried to set selinux to enforcing as well as stopping
iptables, but with no success. The printer is searched by hp-setup tool and is
pingable as well.

Comment 1 Vaclav "sHINOBI" Misek 2007-02-28 13:33:49 UTC
Created attachment 148913 [details]
cups error log

Comment 2 Vaclav "sHINOBI" Misek 2007-02-28 13:50:02 UTC
Small update. I tried to print through other protocols. LPD, JetDirect and hplip
aren't working, but I finally managed to print through IPP. It worked through
others protocols in the past, but approx. 1 month ago it stopped.

Comment 3 Tim Waugh 2007-02-28 14:19:39 UTC
D [28/Feb/2007:14:15:55 +0100] [Job 518] envp[21]="DEVICE_URI=socket://192.168.1
0.10:9100"
[...]
E [28/Feb/2007:14:15:55 +0100] [Job 518] Unable to connect to printer (retrying 
in 30 seconds): Connection reset by peer
[...]
D [28/Feb/2007:14:16:25 +0100] [Job 518] Connected to 192.168.10.10:9100 (IPv4).
..
D [28/Feb/2007:14:16:25 +0100] [Job 518] backendRunLoop(print_fd=0, device_fd=4,
 use_bc=1)
D [28/Feb/2007:14:16:25 +0100] [Job 518] Read 8192 bytes of print data...
D [28/Feb/2007:14:16:25 +0100] [Job 518] Wrote 8192 bytes of print data...
D [28/Feb/2007:14:16:25 +0100] [Job 518] Read 8192 bytes of print data...
E [28/Feb/2007:14:16:25 +0100] [Job 518] Unable to write print data: Broken pipe

The print server is dropping our connections for some reason.  Please capture
the TCP traffic like this:

tcpdump -U -s0 -w jetdirect.pcap port 9100

and try sending a job (using the socket: URI).  After a minute or two press
control-C to stop tcpdump, and attach the jetdirect.pcap file here.  Thanks.

Comment 4 Vaclav "sHINOBI" Misek 2007-02-28 14:37:35 UTC
Created attachment 148920 [details]
requested tcpdump

Comment 5 Tim Waugh 2007-02-28 15:01:59 UTC
The print device is sending a RST as soon as we establish the first connection,
and as soon as we send any data on the second connection.  Not much we can do
about it.

Were there any firmware upgrades performed on the print device in the last few
months?  Are any firmware upgrades available from the manufacturer?

From the point of view of CUPS there's not much we can do -- the device doesn't
want to talk to us.

Comment 6 Vaclav "sHINOBI" Misek 2007-02-28 15:55:56 UTC
Hmmm strange as the printer worked without probs 1 or two months ago. There was
no fw upgrade (I tried to flash the newest one now, but it behaves the same
way), and as I haven't used it for a longer time, I'm unable to find exact
timing (if it should be kernel related etc.). Anyway thanks a lot for your help.

Comment 7 Vaclav "sHINOBI" Misek 2007-02-28 16:02:11 UTC
Errrrrm. I made a series of tests and I find a problem in network aliases in my
machine. After correcting them everything works. I'd like to appologise for
wasting your time and thanks a lot for your help.


Note You need to log in before you can comment on or make changes to this bug.