Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230333 - Epiphany crashes on loading Java applets after updating to epiphany-2.16.3-2.fc6
Summary: Epiphany crashes on loading Java applets after updating to epiphany-2.16.3-2...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany
Version: 6
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 13:30 UTC by Kevin Verma
Modified: 2018-04-11 07:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-15 11:31:43 UTC


Attachments (Terms of Use)
strace.epiphany (deleted)
2007-03-01 10:35 UTC, Anuj Verma (Kevin)
no flags Details
priviously mentioned strace output upon java testing (deleted)
2007-03-10 02:10 UTC, Anuj Verma (Kevin)
no flags Details
bugg buddy collected stack trace upon bz form subbmit upon attachment creation (deleted)
2007-03-10 02:13 UTC, Anuj Verma (Kevin)
no flags Details

Description Kevin Verma 2007-02-28 13:30:57 UTC
Description of problem:
After todays update of FC6 to epiphany-2.16.3-2.fc6, epiphany crashes after
loading any webpage with a java applet. 

Version-Release number of selected component (if applicable):
epiphany-2.16.3-2.fc6

How reproducible:
always

Steps to Reproduce:
1. load URL ot test Java or any java applet page -
www.java.com/en/download/help/testvm.xml 
  
Actual results:

Epiphany crashes

Additional info:
[averma@localhost ~]$ epiphany 
INTERNAL ERROR on Browser End: JavaPluginFactory5 init - no agent?

System error?:: Permission denied

Expected results:
Epiphany works

Comment 1 Anuj Verma (Kevin) 2007-03-01 10:33:32 UTC
also crashes upon loading "about:plugins" in URL bar 

Comment 2 Anuj Verma (Kevin) 2007-03-01 10:35:20 UTC
Created attachment 149006 [details]
strace.epiphany

tried to load the java test url while the strace was captured

Comment 3 Andrew Overholt 2007-03-01 21:52:17 UTC
gcjwebplugin or proprietary JVM?

Comment 6 Kevin Verma 2007-03-05 08:16:45 UTC
(In reply to comment #3)
> gcjwebplugin or proprietary JVM?

Its properitary JVM "j2re1.4.2_02" - please also note that after appying
epiphany extentions todya it at-least does not crashes on loading
"about:plugins" but still crashes on loading any Java VM applet. 

Comment 7 Christopher Aillon 2007-03-05 15:12:15 UTC
Regression from other updates, Martin?

Comment 8 Martin Stransky 2007-03-06 09:27:10 UTC
(In reply to comment #7)
> Regression from other updates, Martin?

Could be. I could not reproduce it on my box so I'll check it on a clear fc6.

Comment 9 Martin Stransky 2007-03-06 12:27:14 UTC
It affects firefox, too.

Comment 10 Anuj Verma (Kevin) 2007-03-06 12:41:21 UTC
Firefox works fine for me so far, I am using it as a stop gap arrangment till
Epiphany is fixed. 

Comment 11 Martin Stransky 2007-03-06 12:56:48 UTC
Hmm, strange. But I can reproduce it, at least.

Comment 12 Martin Stransky 2007-03-06 14:48:49 UTC
Can you please check the latest java? jre-1_5_0_11-linux-i586.rpm

Comment 13 Martin Stransky 2007-03-06 15:48:19 UTC
Hmm, j2re1.4.2_02 crashes with previous packages, too:

firefox-1.5.0.9-2.fc6
epiphany-2.16.3-1.fc6

jre-1_5_0_11 works fine.

Comment 14 Anuj Verma (Kevin) 2007-03-10 01:58:10 UTC
I tried with jre-1_5_0_11 as well, crashed again I need to get this working with
j2re-1.4.2_02-3 more important. However I installed epiphany-debuginfo package
but I had issues getting the BT. I am attaching the strace for now. 

firefox-1.5.0.10-1.fc6
epiphany-2.16.3-2.fc6
epiphany-debuginfo-2.16.3-2.fc6

$ strace -o /tmp/epiphany.3 -r -v -f -t -p5874
--snip--
5874       0.000741
access("/usr/java/j2re1.4.2_02/plugin/i386/ns610-gcc32/libjavaplugin_oji.so",
F_OK) = 0
5874       0.000222
open("/usr/java/j2re1.4.2_02/plugin/i386/ns610-gcc32/libjavaplugin_oji.so",
O_RDONLY) = 33
5874       0.000063 read(33,
"\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\220\220"..., 512) = 512
5874       0.000060 fstat64(33, {st_dev=makedev(253, 4), st_ino=1221817,
st_mode=S_IFREG|0755, st_nlink=1, st_uid=0, st_gid=0, st_blksize=4096,
st_blocks=560, st_size=281904, st_atime=2007/03/10-02:10:11,
st_mtime=2003/09/17-09:21:16, st_ctime=2007/03/09-20:32:48}) = 0
5874       0.000095 mmap2(NULL, 283488, PROT_READ|PROT_EXEC,
MAP_PRIVATE|MAP_DENYWRITE, 33, 0) = 0x5165000
5874       0.000074 mmap2(0x51a3000, 32768, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 33, 0x3d) = 0x51a3000
5874       0.000056 mprotect(0x130000, 3792, PROT_READ|PROT_WRITE) = 0
5874       0.000039 mprotect(0x130000, 3792, PROT_READ) = 0
5874       0.000050 mprotect(0xbfa65000, 4096,
PROT_READ|PROT_WRITE|PROT_EXEC|PROT_GROWSDOWN) = 0
5874       0.000036 mprotect(0xb00a4000, 10485760,
PROT_READ|PROT_WRITE|PROT_EXEC) = 0
5874       0.000034 mprotect(0xb1506000, 10485760,
PROT_READ|PROT_WRITE|PROT_EXEC) = 0
5874       0.000036 mprotect(0xb1f07000, 10485760,
PROT_READ|PROT_WRITE|PROT_EXEC) = 0
5874       0.000032 mprotect(0xb2908000, 10485760,
PROT_READ|PROT_WRITE|PROT_EXEC) = 0
5874       0.000036 mprotect(0xb3309000, 10485760,
PROT_READ|PROT_WRITE|PROT_EXEC) = 0
5874       0.000033 mprotect(0xb3d0a000, 10485760,
PROT_READ|PROT_WRITE|PROT_EXEC) = 0
5874       0.000035 mprotect(0xb470b000, 10485760,
PROT_READ|PROT_WRITE|PROT_EXEC) = 0
5874       0.000034 mprotect(0xb0aa5000, 10485760,
PROT_READ|PROT_WRITE|PROT_EXEC) = 0
5874       0.000045 close(33)           = 0
5874       0.000193 mprotect(0x5165000, 253952, PROT_READ|PROT_WRITE) = 0
5874       0.008838 mprotect(0x5165000, 253952, PROT_READ|PROT_EXEC) = 0
5874       0.000142 write(2, "INTERNAL ERROR on Browser End: ", 31) = 31
5874       0.000155 write(2, "JavaPluginFactory5 init - no age"..., 36) = 36
5874       0.000089 write(2, "\n", 1)   = 1
5874       0.000100 write(2, "System error?:: Success\n", 24) = 24
5874       0.000099
unlink("/home/averma/.gnome2/epiphany/mozilla/epiphany/lock") = 0
5874       0.000240 writev(13, [{"GIOP\1\2\1\5\0\0\0\0", 12}], 1) = 12
5874       0.000233 close(13)           = 0
--snip--

Comment 15 Anuj Verma (Kevin) 2007-03-10 02:08:19 UTC
Through the day trying to understand this issue a new finding had been that
epiphany started crashing more often, even it crashed now while attaching the
previously mentioned attachment. But then Bug Buddy got excited and I got get a
little useless backtrace, I am attaching it here still and request for a bit of
guidence for what more I information I can help for this issue ? 



Comment 16 Anuj Verma (Kevin) 2007-03-10 02:10:42 UTC
Created attachment 149760 [details]
priviously mentioned strace output upon java testing

Comment 17 Anuj Verma (Kevin) 2007-03-10 02:13:03 UTC
Created attachment 149761 [details]
bugg buddy collected stack trace upon bz form subbmit upon attachment creation

Comment 18 Martin Stransky 2007-03-12 10:05:36 UTC
It crashes somewhere in java plug-in. You can probe the next one, stored in 

/usr/java/j2re1.4.2_02/plugin/i386/ns610/libjavaplugin_oji.so

but it crashes for me, too.

Comment 19 Martin Stransky 2007-03-12 14:03:28 UTC
The next problem could be missing /usr/lib/libXp.so.6, but it worked before the
update (right?) so I don't propose it...

Comment 20 Anuj Verma (Kevin) 2007-03-12 18:37:54 UTC
No on this system, I am not missing libXp - libXp-1.0.0-8 

Comment 21 Martin Stransky 2007-03-12 21:05:07 UTC
It crashes because the "navigator.userAgent" string in epiphany-2.16.3-2.fc6 is
too long (it looks like a limit is 128 chars). I hacked a bit the binaries and
it works fine for me now. I'll update CVS tomorrow.

Comment 22 Anuj Verma (Kevin) 2007-03-12 22:14:23 UTC
(In reply to comment #21)
> It crashes because the "navigator.userAgent" string in epiphany-2.16.3-2.fc6 is
> too long (it looks like a limit is 128 chars). I hacked a bit the binaries and
> it works fine for me now. I'll update CVS tomorrow.

Thats a great news, can you please share your workaround for now ?

Comment 23 Martin Stransky 2007-03-13 08:52:13 UTC
I removed string "Epiphany/2.16" from epiphany binaries. Open /usr/bin/epiphany
in some hexa editor (e.g. hexedit), find "Epiphany/2.16" string and place 0x00
instead of the first letter ('E').

Comment 24 Anuj Verma (Kevin) 2007-03-13 18:15:32 UTC
(In reply to comment #23)
> I removed string "Epiphany/2.16" from epiphany binaries. Open /usr/bin/epiphany
> in some hexa editor (e.g. hexedit), find "Epiphany/2.16" string and place 0x00
> instead of the first letter ('E').

Yeah this is working like a charm ! and was the only salvage tonight when
firefox started crashing on me. Many thanks! 

Comment 25 Fedora Update System 2007-03-14 20:31:25 UTC
firefox-1.5.0.10-5.fc6 epiphany-2.16.3-3.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.