Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230331 - IA64 Fully virtualized support fails with "Invalid Argument"
Summary: IA64 Fully virtualized support fails with "Invalid Argument"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Rik van Riel
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 13:07 UTC by Chris Lalancette
Modified: 2018-10-19 19:06 UTC (History)
8 users (show)

Fixed In Version: RHEA-2007-0635
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-07 17:09:54 UTC


Attachments (Terms of Use)
Output from xend when trying to create ia64 fully virtualized guest (deleted)
2007-02-28 13:08 UTC, Chris Lalancette
no flags Details
Minimal fix for ia64 HVM "Invalid Argument" (deleted)
2007-02-28 20:41 UTC, Chris Lalancette
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2007:0635 normal SHIPPED_LIVE xen enhancement update 2007-10-30 15:49:02 UTC

Description Chris Lalancette 2007-02-28 13:07:35 UTC
Description of problem:
Intel and Fujitsu are reporting that the RHEL5 GA kernel can't create fully
virtualized ia64 domains.  It seems to be due to the xen-shadow-enable.patch in
the xen package; removing that patch lets them boot their guests again.  I'll
attach a xend.log from the IT.

Comment 1 Chris Lalancette 2007-02-28 13:08:26 UTC
Created attachment 148912 [details]
Output from xend when trying to create ia64 fully virtualized guest

Comment 2 Aron Griffis 2007-02-28 17:25:16 UTC
This effectively kills the xen/ia64 tech preview.  We need to fix it before 5.0-GA

Comment 3 Prarit Bhargava 2007-02-28 18:09:33 UTC
We CANNOT wait for this to be fixed in U1.  This MUST be fixed prior to 5.0 GA.

Comment 4 Daniel Berrange 2007-02-28 18:16:33 UTC
Simply removing the 'xen-shadow-enable.patch'  from the Xen package will break
i686 & x86_64  HVM guests - causing the 'Cannot allocate memory' bug to return.
 So someone needs to propose an alternate fix which either makes that patch a
no-op on ia64, or provide an add-on patch to explicitly address the ia64 problem
without impacting other archs.


Comment 6 Prarit Bhargava 2007-02-28 18:24:57 UTC

(In reply to comment #4)
> Simply removing the 'xen-shadow-enable.patch'  from the Xen package will break
> i686 & x86_64  HVM guests - causing the 'Cannot allocate memory' bug to return.
>  So someone needs to propose an alternate fix which either makes that patch a
> no-op on ia64, or provide an add-on patch to explicitly address the ia64 problem
> without impacting other archs.
> 

The quick(est) fix is to #ifdef __ia64__ the code.  Ugly, but at least we'll
meet the day0 deadline.


Comment 7 Chris Lalancette 2007-02-28 20:41:44 UTC
Created attachment 148961 [details]
Minimal fix for ia64 HVM "Invalid Argument"

Comment 9 RHEL Product and Program Management 2007-02-28 22:06:39 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being marked as a blocker for this release.  

Please resolve ASAP.

Comment 11 Rik van Riel 2007-03-01 21:38:31 UTC
in xen-3.0.3-26.el5

Comment 19 John Poelstra 2007-08-27 18:42:18 UTC
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot3 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed as soon as possible to
ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

More assistance: If you cannot access bugzilla, please reply with a message to
Issue Tracker and I will change the status for you.  If you need assistance
accessing ftp://partners.redhat.com, please contact your Partner Manager.

Comment 20 John Poelstra 2007-08-31 00:28:55 UTC
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot4 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed *as soon as possible*
to ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.


Comment 21 John Poelstra 2007-09-11 19:21:57 UTC
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot6 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed ASAP to confirm that it
will be included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.

Comment 22 John Poelstra 2007-09-20 04:47:25 UTC
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot7 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed ASAP to confirm that it
will be included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.

Comment 23 John Poelstra 2007-09-26 23:44:53 UTC
A fix for this issue should be included in the packages contained in
RHEL5.1-Snapshot8--available now on partners.redhat.com.  

IMPORTANT: This is the last opportunity to confirm that your issue is fixed in
the RHEL5.1 update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.

Comment 25 errata-xmlrpc 2007-11-07 17:09:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0635.html



Note You need to log in before you can comment on or make changes to this bug.