Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230329 - Gnucash fails to start (wrong scheme modules paths + names).
Summary: Gnucash fails to start (wrong scheme modules paths + names).
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnucash
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 12:40 UTC by Oron Peled
Modified: 2014-03-17 03:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-28 14:12:37 UTC


Attachments (Terms of Use)

Description Oron Peled 2007-02-28 12:40:36 UTC
Description of problem:

Trying to run the latest gnucash aborts with an error message.

Version-Release number of selected component (if applicable):
gnucash-2.0.5-1.fc6

How reproducible:
Simply run this gnucash version.

Actual results:
Gnucash aborts with the following error message:
ERROR: Could not find slib/require.scm in  ("/usr/share/guile/site"
"/usr/share/gnucash/guile-modules" "/usr/share/gnucash/scm" ""
"/usr/share/guile/site" "/usr/share/guile/1.8" "/usr/share/guile")

I located the missing file in /usr/share/slib which is part
of the installed package: slib-3a3-2

After looking in the /usr/bin/gnucash startup script I tried
the following workaround:
  env GUILE_LOAD_PATH=/usr/share gnucash

And gnucash aborted again with the following error message:
ERROR: In procedure open-file:
ERROR: No such file or directory: "/usr/share/slib/mklibcat"



Expected results:


Additional info:

Comment 1 Oron Peled 2007-02-28 14:12:37 UTC
Found the culprit and fixed it:
 - Had another host with a working gnucash.
 - strace -fe open -o out.txt /usr/bin/gnucash
 - Found /usr/share/guile/site/slib/require.scm
 - /usr/share/guile/site/slib is a symlink to /usr/share/slib
 - The link was missing on the faulty host
 - rpmverify gnucash guile slib got clean on both hosts.
 - rpmquery -f /usr/share/guile/site/* on the good
   host shows no package owns it.
 - rpmquery --scripts on the suspected packages shows nothing relevant.
 - Hmmm..... maybe another package is involved? which?
 - Arrrggg... those triggers.
 - rpmquery --triggers guile
 - Manually run these commands on the faulty host.
 - All is in order.


Note You need to log in before you can comment on or make changes to this bug.