Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230315 - eclipse-phpeclipse severely broken
Summary: eclipse-phpeclipse severely broken
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-phpeclipse
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brandon Holbrook
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 09:14 UTC by Karl Lattimer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-01 12:31:51 UTC


Attachments (Terms of Use)
eclipse log file (deleted)
2007-02-28 09:14 UTC, Karl Lattimer
no flags Details
A second eclipse log problem (deleted)
2007-03-01 11:19 UTC, Karl Lattimer
no flags Details
yet another log file (deleted)
2007-03-01 12:19 UTC, Karl Lattimer
no flags Details

Description Karl Lattimer 2007-02-28 09:14:42 UTC
Description of problem:
Trying to open php files in eclipse using the php-eclipse plugin reports an
error asking the user to look at the log file

Version-Release number of selected component (if applicable):
eclipse-platform 3.2.2-1
eclipse-phpeclipse 1.1.8-16

How reproducible:
Always

Steps to Reproduce:
1. Start eclipse
2. Open a php file
  
Actual results:
Error report is spat out requesting the user look at the log file for more
information, incidently phpeclipse does not inform the user where the log file
is. Log file is attached.

Expected results:
The file to open

Additional info:
I have uninstalled, reinstalled, and wiped out my projects, all my local eclipse
configuration no less than 5 times trying to get eclipse to actually install
properly, eventually I managed to get a workspace to load. Then after getting a
workspace to load still not actually being able to use it. These problems with
the eclipse install, and eclipses inability to gracefully handle errors (with
.metadata folders) have persisted since fedora core 5. As a result I have made
the decision today to switch to using ubuntu, after being a loyal redhat user
since 5.2

Comment 1 Karl Lattimer 2007-02-28 09:14:42 UTC
Created attachment 148901 [details]
eclipse log file

Comment 2 Ben Konrath 2007-02-28 14:17:52 UTC
Reassigning to component owner.

Comment 3 Brandon Holbrook 2007-02-28 20:03:29 UTC
I am unable to reproduce this error on both x86_64 and i386.  I have yum erased
eclipse-* and installed the versions you mentioned, also starting with a brand
new workspace and starting a brand new project and creating a brand new PHP
file.  In all cases on the 3 computers I tried, the editor opens fine and I can
edit and save and close and open my PHP files all day.

What is listed in your Help > Software Updates > Manage Configuration

Can you reproduce this on another machine (preferably one with a fresh FC6
install) ?  If so, can you help me reproduce the crash?

Comment 4 Karl Lattimer 2007-03-01 09:21:34 UTC
Can you create a method of cleaning my machine of all eclipse configuration and
stray metadata folders and all the rest of the nonsense that I must be missing? 

I have another problem on my other FC6 machine where the workspace won't even
open. Nothing but problems eclipse has been since FC5 when I had phpeclipse,
pydev and my cdt working perfectly!

I will help you debug the issue if you can figure out a reasonably sensible way
to proceed. Baring in mind that I cannot fresh install.

I have just removed;
/usr/share/eclipse
~/.eclipse

and moved ~/workspace to ~/workspace.old

[root@localhost klattimer]# find . -name .metadata
./workspace.old/.metadata

I've also openened another bug while trying to sort this issue out #230528

Comment 5 Karl Lattimer 2007-03-01 11:19:42 UTC
Created attachment 149009 [details]
A second eclipse log problem

A second eclipse log problem

Comment 6 Karl Lattimer 2007-03-01 11:21:23 UTC
After uninstalling and reinstalling eclipse again i now get this error before
the workbench actually starts.

I currently have the following eclipse RPMs installed

eclipse-jdt-3.2.2-1.fc6
eclipse-phpeclipse-1.1.8-16.fc6
eclipse-rcp-3.2.2-1.fc6
eclipse-bugzilla-0.2.4-3.fc6
eclipse-platform-3.2.2-1.fc6
eclipse-ecj-3.2.2-1.fc6
eclipse-pde-runtime-3.2.2-1.fc6
eclipse-changelog-2.3.3-2.fc6
eclipse-platform-3.2.2-1.fc6
eclipse-cdt-3.1.1-8.fc6
eclipse-jdt-3.2.2-1.fc6

I'm betting that one of the dependencies isn't included in the packages.

Comment 7 Karl Lattimer 2007-03-01 11:22:59 UTC
Incidentally comment #4 I removed those folders AFTER uninstalling the RPMS via
pirut

Comment 8 Karl Lattimer 2007-03-01 12:05:21 UTC
Appears the last problem was related to a stale CVS install of the phpeclipse
plugin. I have since removed that and am yet again re-installing eclipse and
phpeclispe

Comment 9 Karl Lattimer 2007-03-01 12:19:22 UTC
Created attachment 149012 [details]
yet another log file

Comment 10 Karl Lattimer 2007-03-01 12:31:51 UTC
After discovering stale files in /usr/lib/eclipse and /usr/lib64/eclipse and
removing them as well as all other folders/files associated with eclipse I could
find I have provided yet another log file.

Does anyone actually know how to decifer the important parts from these logs?

These seem important,
java.lang.RuntimeException: No application id has been found.
!MESSAGE Missing required bundle org.eclipse.swt_[3.2.0,4.0.0).

I have now re-installed libswt3-gtk2 i386 and x86_64 my workbench now starts
again, and I can now open php files.

It appears any stale files left over in lib/eclipse cause this issue. It has
been a rediculous situation trying to trace this problem as very little
understandable information is put out in the eclipse log file, some HUMAN
readable errors would be nice. 

The ability for eclipse to actually sense a problem and avoid it would also be nice.

Am I asking the earth to have eclipse work sensibly?

Thanks for your help, although I eventually solved it on my own, please make
future phpeclipse releases remove all stale files (even those installed via the
update manager) from the system thereby preventing this issue re-occurring. 






Note You need to log in before you can comment on or make changes to this bug.