Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230311 - [NFSv3] reply size of readdir/readdirplus procedure alaways larger than request [NEEDINFO]
Summary: [NFSv3] reply size of readdir/readdirplus procedure alaways larger than request
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Steve Dickson
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 06:10 UTC by yjwei
Modified: 2015-11-17 10:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-17 10:02:52 UTC
steved: needinfo? (yjwei)


Attachments (Terms of Use)
patch of this bug (deleted)
2007-02-28 06:10 UTC, yjwei
no flags Details | Diff

Description yjwei 2007-02-28 06:10:05 UTC
Description of problem:
  NFSv3 reply size of readdir/readdirplus procedure alaways larger than request.
  RFC1813 3.3.16 Procedure 16: READDIR - Read From Directory has following 
define:
      count
         The maximum size of the READDIR3resok structure, in
         bytes.  The size must include all XDR overhead. The
         server is free to return less than count bytes of
         data.
  but the kernel to used this count argument as the size of dirlist3, exclude 
the size of post_attr_attr and cookieverf. So the reply size alaways larger 
than request.

Comment 1 yjwei 2007-02-28 06:10:05 UTC
Created attachment 148897 [details]
patch of this bug

Comment 2 Steve Dickson 2007-03-22 12:35:03 UTC
How does this help the server (or client) process 
readdirplus-es? 

Comment 3 yjwei 2007-03-27 05:58:24 UTC
If server send a READDIR or READDIRPLUS reply to client which is larger than 
client's request, client may treat it with RPC_GARBAGE and still retry. The 
kernel's implement does not accord with the RFC's define. I have a test case 
about this, reply a large reddirplus to RHEL3U8 nfs client, which let following 
umount kernel painic, I'm not sure whether this is the real reason.

Comment 4 yjwei 2007-04-25 02:29:56 UTC
The implement of kernel does not in correspondence with the RFC, does anyone 
think this problem need to be fixed?

Comment 7 Steve Dickson 2007-04-25 17:23:27 UTC
How reproducible is your test case? Unfortunately Oops at 
umount time can be caused by a number of things... 

Also are you seeing any interoperability problems? I 
would suspect we would see this type of problem if 
not adhering to the spec is a problem?

Comment 8 RHEL Product and Program Management 2007-04-25 21:01:25 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 9 RHEL Product and Program Management 2007-09-07 19:54:55 UTC
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.

Comment 10 Steve Whitehouse 2015-11-17 10:02:52 UTC
This was put into needinfo years ago and has had no updates. Comment #6 says it is very low priority. At this stage I don't think we should be fixing this unless it is high priority at least, so going to close it. Please reopen if this is not correct.


Note You need to log in before you can comment on or make changes to this bug.