Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230304 - autofs in RHEL 3 Update 8 fail to check the NIS automount map
Summary: autofs in RHEL 3 Update 8 fail to check the NIS automount map
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs
Version: 3.8
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Moyer
QA Contact: Brock Organ
URL:
Whiteboard:
: 230300 230301 230302 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 02:59 UTC by Wesly Chen
Modified: 2007-11-17 01:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 17:41:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wesly Chen 2007-02-28 02:59:20 UTC
Description of problem:
 My Redhat Enterprise Linux WS 3.0 Update 7 upgraded to Update 8, then my autofs
failed.
It seems to me that the version of autofs on update 8. autofs-4.1.3-186, cause
the problem.
So all my NIS automount maps fail.

   When I start the autofs (# service autofs restart), it shows "Not Mountpoints
Defined" even though there are a lot of mount points defined in NIS. Unless I
put those mount points into /etc/auto_<map files>.

   Temporarily work around is roll back the autofs to autofs-4.1.3-168 which
comes with Update 7.


Version-Release number of selected component (if applicable):
autofs-4.1.3-186

How reproducible:


Steps to Reproduce:
1. install autofs-4.1.3-186
2. create NIS map auto_master with "/home  auto_home" in it 3. Create NIS map
auto_home with "user1  <NFS_server>:/users/user1"
4. Make sure <NFS_server>:/users/user1 is shared out on NFS 5. echo
"+auto_master" > /etc/auto.master 6. /etc/rc.d/init.d/autofs start
  
Actual results:
# /etc/init.d/autofs start
Starting automount: No Mountpoints Defined    [  OK  ]

Expected results:
# /etc/init.d/autofs start
Starting automount:        [  OK  ]

Additional info:
1.
$ grep -v ^# /etc/sysconfig/autofs
LOCALOPTIONS=""
DAEMONOPTIONS="--timeout=60"
LDAPAUTOMASTER=""
UNDERSCORETODOT=1
DISABLE_DIRECT=1
ONE_AUTO_MASTER=0
GHOSTDIRS=""
BASEDN=

2.
$ grep automount /etc/nsswitch.conf
automount:  files nis

3. 
$ grep -v ^# /etc/auto.master
+auto_master

4. 
$ ypcat -k auto_master
/user auto_home

5.
$ ypcat -k auto_home
*  <NFS server name>:/vol/fvol1/users/&

6.
$ uname -r
2.4.21-47.0.1.ELsmp

7. 
$cat /etc/redhat-release
Red Hat Enterprise Linux WS release 3 (Taroon Update 8)

Comment 1 Wesly Chen 2007-02-28 22:24:32 UTC
If I modify auto_master
from
/home   auto_home
to
/home   yp:auto_home
and it works.

However, the syntax
/home   yp:auto_home
doesn't work on Solaris NIS client.
It seems that autofs has backward compatible issue.

Comment 2 Wesly Chen 2007-03-01 00:38:32 UTC
If I create /etc/auto_home
with "+auto_home" in it, then it works.

However, this requires all the automount maps in auto.master have local map 
files.
It defeat the purpose of NIS automount maps.

Comment 3 Jeff Moyer 2007-03-05 18:06:30 UTC
*** Bug 230300 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Moyer 2007-03-05 18:06:51 UTC
*** Bug 230301 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Moyer 2007-03-05 18:06:59 UTC
*** Bug 230302 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Moyer 2007-03-12 14:30:20 UTC
Hi,

Why do you set UNDERSCORETODOT to 1 in your configuration:
UNDERSCORETODOT=1

If you specify auto_master and this variable is set to one, it will instead
search for auto.master.  The same goes for any included maps.  Please set this
variable to 0 and your problem should go away.

For the longer description, I introduced a utility to determine the source of a
map in an effort to support included maps.  In the past, I have had bugs filed
against the UNDERSCORETODOT mechanism, since it only converted the underscores
in a few select maps.  So, when making the switch to a general purpose utility,
I fixed that bug.  This may have introduced the regression you are seeing.

-Jeff

Comment 7 Wesly Chen 2007-03-12 17:36:13 UTC
Yes, it fixed my issue.
By default, the autofo package come in Redhat set UNDERSCORETODOT=1, that 
introduce my problem.
I would suggest that set UNDERSCORETODOT=0 in /etc/sysconfig/autofs by default.


Comment 8 Jeff Moyer 2007-03-12 17:41:15 UTC
(In reply to comment #7)
> Yes, it fixed my issue.
> By default, the autofo package come in Redhat set UNDERSCORETODOT=1, that 
> introduce my problem.
> I would suggest that set UNDERSCORETODOT=0 in /etc/sysconfig/autofs by default.

I agree with you in principle, but in practice I do not want to introduce
further regressions.  The UNDERSCORETODOT was defaulted to 1 because that is the
way it was in the past (in fact, it was not always tunable).


Note You need to log in before you can comment on or make changes to this bug.