Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230298 - Rebuild galeon for new firefox-1.5.0.10-1.fc6
Summary: Rebuild galeon for new firefox-1.5.0.10-1.fc6
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: galeon
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-28 01:58 UTC by Alex Lancaster
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-28 07:39:17 UTC


Attachments (Terms of Use)

Description Alex Lancaster 2007-02-28 01:58:34 UTC
Description of problem:
(sigh).  Yet again, can't upgrade because galeon needs a rebuild against new
firefox.

Version-Release number of selected component (if applicable):
galeon-2.0.3-5.fc6

How reproducible:
Always.

Steps to Reproduce:
1. sudo yum upgrade
  
Actual results:
--> Running transaction check
--> Processing Dependency: gecko-libs = 1.8.0.9 for package: galeon
--> Finished Dependency Resolution
Error: Missing Dependency: gecko-libs = 1.8.0.9 is needed by package galeon


Expected results:
Upgrade should proceed.

Additional info:
Does the firefox maintainer *still* not communicate to the galeon maintainer to
make sure the upgrades proceed smoothly.  This has happened *every* time firefox
or mozilla has been upgraded, which normally happens about every 6 months. 
Hopefully the Core+Extra merge will make this a thing of the past.... ;)

Comment 1 Denis Leroy 2007-02-28 07:39:17 UTC
I was telling Phillip Langdale how quickly i get bug reports when galeon is
broken by a firefox update, just as a proof of galeon still being popular out there.

Even if Chris Aillon notified me of firefox updates, there's nothing I could do
since they do not go through the same build system, i.e. i have to wait until
firefox is released before i can even rebuild galeon. The good thing is this
will come to an end soon with the merge, finally...

build is queued, for FC-6.



Note You need to log in before you can comment on or make changes to this bug.