Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230293 - Cannot suspend because libata claims drive is still active
Summary: Cannot suspend because libata claims drive is still active
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-27 23:53 UTC by Stewart Adam
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-25 21:46:29 UTC


Attachments (Terms of Use)

Description Stewart Adam 2007-02-27 23:53:00 UTC
Description of problem:
My system will not suspend when click gnome-power-manager's 'suspend' button
because it seems libata is having trouble stopping devices. Here are the
relevant log messages:

Feb 27 17:49:15 MyBox kernel: SCSI device sda: write cache: enabled, read cache:
enabled, doesn't support DPO or FUA
[...]
Feb 27 17:50:00 MyBox gnome-power-manager: (admin) Suspending computer because
user clicked suspend from tray menu
Feb 27 17:50:03 MyBox kernel: ata7: suspend failed, device 0 still active
Feb 27 17:50:03 MyBox kernel: pci_device_suspend():
ata_pci_device_suspend+0x0/0x2b [libata]() returns -16
Feb 27 17:50:03 MyBox kernel: suspend_device(): pci_device_suspend+0x0/0x4b()
returns -16
[...]
Feb 27 17:50:03 MyBox kernel: ATA: abnormal status 0x7F on port 0x00016807
Feb 27 17:50:03 MyBox kernel: ata7.00: configured for UDMA/33
Feb 27 17:50:03 MyBox kernel: ata1: soft resetting port
Feb 27 17:50:03 MyBox kernel: Some devices failed to suspend

Version-Release number of selected component (if applicable):
2.6.20-1.2947.fc7

How reproducible:
Always

Steps to Reproduce:
1. Enable can_suspend in gnome-power-manager's gconf preferences if needed
2. Click the panel icon
3. Select 'Suspend'
  
Actual results:
The system begins to suspend (I can hear drives power down, screen goes black)
then after about half a second the screen comes back to life and the drives spin
back up.

Expected results:
The system suspends

Additional info:
Not sure if this helps or not, but relevant hardware is:
Mobo: Gigabyte GA-965P-S3
HDD: SATA WD Raptor 150GB
(Using the Intel ICH8 SATA controller, not the Gigabyte one as the Gigabyte one
is much, much slower.)
GPU: nVidia 7300 GS, PCI-E

Comment 1 Richard Hughes 2007-05-24 10:37:24 UTC
Does this still happen with rawhide? Can you also check for common problems here
http://people.freedesktop.org/~hughsient/quirk/ please. Thanks.

Comment 2 Stewart Adam 2007-05-25 21:46:29 UTC
This doesn't occur anymore, although my system doesn't resume from the suspend..
But that's for another bug...


Note You need to log in before you can comment on or make changes to this bug.