Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230256 - NetworkManager connected to the wired network when it's unplugged
Summary: NetworkManager connected to the wired network when it's unplugged
Keywords:
Status: CLOSED DUPLICATE of bug 194124
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
: 196684 235233 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-27 20:25 UTC by Aurelien Bompard
Modified: 2018-04-11 12:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-07 17:26:08 UTC


Attachments (Terms of Use)

Description Aurelien Bompard 2007-02-27 20:25:00 UTC
Description of problem:
NetworkManager says it managed to connect to the wired network, but the cable is
unplugged.


Version-Release number of selected component (if applicable):
NetworkManager-0.6.5-0.3.cvs20061025.fc7

How reproducible:
Always

Steps to Reproduce:
1. Plug the cable, NetworkManager connects properly
2. Turn off the computer
3. Unplug the cable
4. Turn on the computer
5. NetworkManager "connects" to the wired network, and gets IP 169.254.3.49/16
  
Expected results:
NetworkManager should say that no network is available

Additional info:
mii-tool correctly reports that eth0 has no link.

Comment 1 Bill Nottingham 2007-03-02 17:33:21 UTC
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.

Comment 2 Matěj Cepl 2007-03-09 00:16:37 UTC
*** Bug 196684 has been marked as a duplicate of this bug. ***

Comment 3 Matěj Cepl 2007-03-09 00:31:54 UTC
Could you please post output of the command
uname -a
I am suspicious that it may be XEN related, so I won't to eliminate that.

Comment 4 Aurelien Bompard 2007-03-09 11:02:58 UTC
2.6.20-1.2975.fc7
I did the test with a previous kernel, but I never installed any Xen-related
kernel on this laptop.
I'll reboot as soon as possible to test if it still occurs with this kernel.

Comment 5 Aurelien Bompard 2007-03-09 12:12:19 UTC
I'm still having this bug with this kernel. However it's not 100% reproductible
: sometimes the nm-applet shows that the network is disconnected after booting,
somtimes it tries to connect and finds a ghost wired network.
Last time the IP was 169.254.3.49/255.255.0.0 and the reported speed was 65535
Mb/s (pretty good card :))

Comment 6 Aurelien Bompard 2007-03-15 08:34:12 UTC
Still happens with kernel 2.6.20-1.2986.fc7 and
NetworkManager-0.6.5-0.3.cvs20061025.fc7

Comment 7 Tyler Owen 2007-05-06 14:53:15 UTC
I am seeing this behavior with F7t4 using NetworkManager-0.6.5-2.fc7 and
kernel-2.6.21-1.3139.fc7

Comment 8 Osma Ahvenlampi 2007-05-21 21:21:15 UTC
Same here; kernel-2.6.21-1.3163.fc7 and NetworkManager-0.6.5-2.fc7

No such issues with FC6 previously installed on the same machine.

Comment 9 Bastien Nocera 2007-05-21 21:58:11 UTC
*** Bug 235233 has been marked as a duplicate of this bug. ***

Comment 10 Bastien Nocera 2007-05-21 21:58:59 UTC
It went away with kernel-2.6.21-1.3144.fc7, and then came back...

Comment 11 Bastien Nocera 2007-06-07 17:26:08 UTC
Dupe of a soon-to-be-fixed-in-Fedora bug

*** This bug has been marked as a duplicate of 194124 ***


Note You need to log in before you can comment on or make changes to this bug.