Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230240 - cannot read Flash card
Summary: cannot read Flash card
Keywords:
Status: CLOSED DUPLICATE of bug 230155
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-27 17:58 UTC by Florin Andrei
Modified: 2013-03-06 03:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-27 18:23:54 UTC


Attachments (Terms of Use)
screenshot (deleted)
2007-02-27 17:58 UTC, Florin Andrei
no flags Details

Description Florin Andrei 2007-02-27 17:58:55 UTC
Description of problem:
While being logged in to my Gnome desktop:
I plugged in the USB port a 4-port Flash card reader. It showed up in the
Computer window as 4 new drive icons (see attached screenshot).
Then I plugged into the reader an SD card. An error showed up, saying:

Cannot mount volume.
Error org.freedesktop.Hal.PermissionDenied.
Permission denied: Not in active session

Version-Release number of selected component (if applicable):
hal-0.5.9-0.git20070218.fc7

How reproducible:
only tried once, I'm in a hurry

Steps to Reproduce:
1. see above
2. 
3.
  
Actual results:
can't read card

Expected results:
duh

Additional info:

Comment 1 Florin Andrei 2007-02-27 17:58:56 UTC
Created attachment 148879 [details]
screenshot

Comment 2 Florin Andrei 2007-02-27 18:02:39 UTC
I unplugged the card, unplugged the reader, then logged out.
Plugged back the reader, logged in (so I'm logged in after the reader was
connected).
Plugged the card back in.

Same error.

Comment 3 David Zeuthen 2007-02-27 18:06:17 UTC
If you're running SELinux in enforcing mode, please close as dupe of bug 230155

If you're not logging in via gdm, please close as dupe of bug 228110

Thanks.

Comment 4 Florin Andrei 2007-02-27 18:14:12 UTC
SELinux is enforcing and I'm using gdm.
But I'm doing "tail -f /var/log/audit/audit.log" and there are no messages when
the error occurs. Is it still a SELinux problem?
If it is, what can I do to enable this functionality (other than switching from
enforcing mode which I do not want to do)?

Comment 5 David Zeuthen 2007-02-27 18:23:54 UTC

*** This bug has been marked as a duplicate of 230155 ***

Comment 6 David Zeuthen 2007-02-27 18:26:25 UTC
I'm not sure why SELinux is logging errors - that's also a problem in 230155...

Comment 7 Florin Andrei 2007-02-27 18:28:29 UTC
Thanks, I'll watch the other bug then.

Comment 8 Bill Nottingham 2007-03-02 17:28:43 UTC
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.


Note You need to log in before you can comment on or make changes to this bug.