Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230236 - Package Updater Dump Information
Summary: Package Updater Dump Information
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 229828 230568 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-27 17:05 UTC by Al Cranford
Modified: 2016-07-11 19:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-16 15:00:20 UTC


Attachments (Terms of Use)
Dump Information provided by OS upon failure (deleted)
2007-02-27 17:05 UTC, Al Cranford
no flags Details

Description Al Cranford 2007-02-27 17:05:56 UTC
Description of problem: When I attempt to update packages via the "Package
Updater" I get the following Dump when I click the "Apply Updates" button:

Component: Software Updater
Summary: TBccefa5c9 yumRepo.py:426:__get:RepoError: failure:
nspr-devel-4.6.5-0.6.0.fc6.i386.rpm from updates: [Errno 256] No more mirrors to
try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 433, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 559, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 324, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 150, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 760, in
downloadHeader
    cache=repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 454, in getHeader
    cache=cache,
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 426, in __get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
RepoError: failure: nspr-devel-4.6.5-0.6.0.fc6.i386.rpm from updates: [Errno
256] No more mirrors to try.

Local variables in innermost frame:
e: [Errno 256] No more mirrors to try.
start: 440
url: None
text: None
self: updates
cache: True
reget: None
relative: nspr-devel-4.6.5-0.6.0.fc6.i386.rpm
headers: ()
checkfunc: (<bound method PackageUpdater.verifyHeader of
<__main__.PackageUpdater object at 0x848e84c>>,
(<yum.sqlitesack.YumAvailablePackageSqlite object at 0x97a792c>, 1), {})
copy_local: 1
end: 10829
local: //var/cache/yum/updates/headers/nspr-devel-4.6.5-0.6.0.fc6.i386.hdr


Version-Release number of selected component (if applicable):


How reproducible:
Two out of two times

Steps to Reproduce:
1. View Updates
2. Apply Updates
3.
  
Actual results:


Expected results:


Additional info:
Attempted to perform system updates via "yum update" and after having multiple
"Header is not complete" on all mirrors for the
.../i386/elfutils-libelf-devel-0.126-1.fc6.i386.rpm file yum comcluded with the
following:
Error: failure: elfutils-lebelf-devel-0.126-1.fc6.i386.rpm from updates: [Errno
256] No more mirrors to try.

Comment 1 Al Cranford 2007-02-27 17:05:56 UTC
Created attachment 148875 [details]
Dump Information provided by OS upon failure

Comment 2 Adrien Bustany 2007-04-12 10:00:09 UTC
Well that happens sometimes when yum tried to download the package list from
differents mirrors and the checksum failed, or when your internet link is
down... It is not a yum or pup bug, though pup crashes on it (whereas it should
just pop up an error window).

Comment 3 Jeremy Katz 2007-04-16 15:00:20 UTC
This should get caught a lot better with the pirut in F7

Comment 4 Jeremy Katz 2007-04-16 15:01:03 UTC
*** Bug 230568 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2007-04-16 15:01:53 UTC
*** Bug 229828 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.