Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230208 - BUG using expat and php (request upgrade to expat-2.0.0)
Summary: BUG using expat and php (request upgrade to expat-2.0.0)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: expat
Version: 3.7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-27 14:46 UTC by Jozeph Brasil
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 18:38:20 UTC


Attachments (Terms of Use)

Description Jozeph Brasil 2007-02-27 14:46:36 UTC
Quick answer:
The steps to fix it vary greatly, depending on your system, and which fix would
be less invasive. I don't know exactly which versions are affected, but the
information I have is that if you upgrade to any php 5.x, or downgrade to any
php 4.3.x, or upgrade expat to > 2.0, then the problem goes away.

Long answer:
There are certain versions of expat (XML parser) -- or PHP's integration with
expat -- that do not preserve whitespace in text nodes. At least for now,
ModernBill expects that whitespace to be preserved in many cases. Many difficult
support tickets involve this issue, so I added this test with the information we
have on the problem at the moment.

Comment 1 Joe Orton 2007-02-28 11:15:33 UTC
Thanks for reporting this issue.  Can you give a reproduction case for the bug
in question?

Comment 2 Jozeph Brasil 2007-02-28 13:26:34 UTC
This bug occurs using PHP applications, just read Quick answer. More details in
php discussion lists.

I've reported this because I'm one of the users affected by this bug using
MODERNBILL (http://www.modernbill.com).

Comment 3 Joe Orton 2007-04-11 08:42:34 UTC
There is not enough information here to be able to diagnose the problem.  Can
you give a concise description of the bug in question?

Comment 4 RHEL Product and Program Management 2007-10-19 18:38:20 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.