Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230189 - Default install of psi unusable without SSL support
Summary: Default install of psi unusable without SSL support
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: psi
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 240663 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-27 11:04 UTC by Hans Ulrich Niedermann
Modified: 2008-01-07 01:57 UTC (History)
1 user (show)

Fixed In Version: psi-0.11-1.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-07 01:57:49 UTC


Attachments (Terms of Use)

Description Hans Ulrich Niedermann 2007-02-27 11:04:06 UTC
Description of problem:

  psi depends on qca, but that does not install the required qca-tls package.

Version-Release number of selected component (if applicable):

  psi-0.10-5.fc6
  qca-1.0-8.fc6

How reproducible:

  Every time.

Steps to Reproduce:
0. Make sure neither psi, qca, or qca-tls is installed.
1. "yum install psi"
  
Actual results:

  Starting psi and checking the [X] SSL checkbox results in an error message
that the SSL plugin was not installed.

Expected results:

  psi should just work with SSL. Non-working SSL support may have been excusable
in 1997, but this is the year 2007 now.

Additional info:

Comment 1 Aurelien Bompard 2007-02-27 16:36:00 UTC
qca-tls is a plugin. As such, it cannot be strictly required by the package. The
next version of RPM is said to have a "Suggests" flag, I'll use that when it's
available.
In the meantime, having a hard Require on a plugin defeats the purpose of it
being a plugin.

To make it easier to end users to figure out what's missing, the last line of
the package's description is :
"If you want SSL support, install the qca-tls package."

I'm open to suggestions to make it even easier for users.

Comment 2 Aurelien Bompard 2007-05-19 17:26:54 UTC
*** Bug 240663 has been marked as a duplicate of this bug. ***

Comment 3 Andreas Thienemann 2007-06-26 18:27:52 UTC
While it may be true that qca-tls is a plugin psi should by default be able to
use ssl.

Therefore I'd argue that for usability sake a hard require on qca-tls should be
inserted into the next update. If it is a plugin or not does not really matter
for the functionality. If psi would dlopen openssl.so which is not being picked
up by the generic rpm library dependency check one would still manually add
openssl to the requirement list.

About the suggest feature, this is planned for the next rpm release, it is
however unclear when fedora will upgrade to the next rpm release. Therefore
we're stuck with require at the moment.

Please add the qca-tls requirement to the package until suggests is available.

Comment 4 Till Maas 2008-01-07 01:57:49 UTC
psi-0.11-1.fc7 in Fedora 7 requires qca-ossl, so this bug is fixed there imho.
Pleaae reopen it, in case I am wrong.


Note You need to log in before you can comment on or make changes to this bug.