Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230149 (compiz-place-plugin) - Windows open too high on screen, menu bar hidden under top panel
Summary: Windows open too high on screen, menu bar hidden under top panel
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: compiz-place-plugin
Product: Fedora
Classification: Fedora
Component: compiz
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
: 202720 217131 227877 232776 381761 (view as bug list)
Depends On:
Blocks: 245495
TreeView+ depends on / blocked
 
Reported: 2007-02-26 21:19 UTC by Jim
Modified: 2018-04-11 17:09 UTC (History)
9 users (show)

Fixed In Version: 0.7.6-2.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-22 20:45:01 UTC


Attachments (Terms of Use)

Description Jim 2007-02-26 21:19:10 UTC
Description of problem:
Whenever I open a new window the new window always appears too high on the
desktop, with the title bar underneath the top panel.  This is the same as the
problem reported here: http://ubuntuforums.org/showthread.php?t=249002

Version-Release number of selected component (if applicable):
compiz-0.3.6-2.fc6.src.rpm

How reproducible:
always

Steps to Reproduce:
1. Go to "System->Proferences->Desktop Effects"
2. Click the "Enable Desktop Effects" button so that it becomes enabled and then
click the "close" button.
3. Open any new program, its windows will be too high.
  
Actual results:
New windows are too high, title bar is hidden.

Expected results:
New windows should not open below a panel.

Additional info:
To fix this follow these steps:
1.  Run 'gconf-editor' (must do this under your user account, not root)
2.  Add "place" to the bottom of this key: "/apps/compiz/general/allscreens/   
options/active_plugins" (I found this key here:
http://www.go-compiz.org/index.php?title=Gconf- Editor)
3.  Close gconf-editor and the change should immediately take affect

IMHO the "place" plugin should be enabled by default.

Comment 1 Jim 2007-02-26 21:22:26 UTC
Forgot to mention that although freenx doesn't appear to be able to use the
compiz desktop effects, it still suffers from this same bug.  Even after using
gconf to enable the "place" plugin my windows still start too high within my
freenx sessions.  I don't know how to fix this problem in freenx.

Comment 2 Sam Varshavchik 2007-03-02 01:27:01 UTC
This happens to me too.  After enabling compiz, newly windows are opened too
high, hiding the top frame.

This happens even if I remove the top panel.  New windows are opened with their
top frame completely off screen.

I confirm that adding the place plugin, using gconf, fixes the problem.

This should definitely be the default configuration.


Comment 3 Steve 2007-03-02 13:28:21 UTC
I have the same thing here. Thanks for the workaroud Jim Johnson!

Comment 4 Kristian Høgsberg 2007-03-28 21:47:37 UTC
*** Bug 232776 has been marked as a duplicate of this bug. ***

Comment 5 Steve 2007-03-28 21:57:35 UTC
seems to be fixed now..

Comment 6 Kristian Høgsberg 2007-03-28 22:01:18 UTC
*** Bug 217131 has been marked as a duplicate of this bug. ***

Comment 7 Christopher Brown 2007-03-28 23:04:33 UTC
(In reply to comment #5)
> seems to be fixed now..

Not for me it isn't. I am running F7T3 and it still has the same problem. I
cannot emphasise how annoying this is. I agree with #2 - this should be default
configuration unless there is an over-riding reason for it not to be.

Comment 8 Kristian Høgsberg 2007-03-29 02:18:52 UTC
*** Bug 227877 has been marked as a duplicate of this bug. ***

Comment 9 Matěj Cepl 2007-07-12 15:23:37 UTC
*** Bug 202720 has been marked as a duplicate of this bug. ***

Comment 10 Kristian Høgsberg 2007-08-14 18:55:34 UTC
Is this still a problem? Does 

  gconftool-2 --unset /apps/compiz/general/allscreens/options/active_plugins

and then log out and back in help?


Comment 11 Dave Russell 2007-08-14 21:23:25 UTC
Nope that doesn't help, F7 is still broken for me in this respect.

Unfortunately your workaround doesn't help either.

I'm currently working with desktop effects disabled to make the machine usable.


Comment 12 Kristian Høgsberg 2007-08-14 21:52:46 UTC
Sorry, I should have linked to the latest build:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=102411

any better?

Comment 13 Kristian Høgsberg 2007-08-15 22:30:55 UTC
The latest build:

  compiz-0.5.2-5.0ec3ec.fc8.src.rpm

should fix this, along with the gconftool-2 workaround mentioned in comment 10.
 Download builds here or in rawhide tomorrow:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=104128



Comment 14 Dave Russell 2007-08-16 11:06:43 UTC
hmm, I've just pulled the compiz-fusion stuff from http://blog.kagesenshi.org
which certainly did fix all of my issues.

I have another affected machine that is still vanilla updated F7 though, so I'll
give those updated rpms a try at the weekend.

Any other deps required when applying to F7?

Comment 15 Steve 2007-08-16 14:58:44 UTC
it appears also again in rawhide. plugin "place" is missing.

compiz-0.5.2-4.0ec3ec.fc8

Comment 16 Matěj Cepl 2008-01-31 16:17:19 UTC
*** Bug 381761 has been marked as a duplicate of this bug. ***

Comment 17 Bug Zapper 2008-05-14 02:38:55 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 18 Fedora Update System 2008-06-14 06:26:48 UTC
ccsm-0.7.6-2.fc9,compizconfig-python-0.7.6-1.fc9,compizconfig-backend-kconfig-0.7.6-1.fc9,compizconfig-backend-gconf-0.7.6-1.fc9,libcompizconfig-0.7.6-1.fc9,compiz-fusion-extras-0.7.6-1.fc9,compiz-fusion-0.7.6-1.fc9,compiz-0.7.6-2.fc9 has been submitted as an update for Fedora 9

Comment 19 Fedora Update System 2008-06-16 23:33:31 UTC
ccsm-0.7.6-2.fc9, compizconfig-python-0.7.6-1.fc9, compizconfig-backend-kconfig-0.7.6-1.fc9, compiz-fusion-extras-0.7.6-1.fc9, compizconfig-backend-gconf-0.7.6-1.fc9, libcompizconfig-0.7.6-1.fc9, compiz-fusion-0.7.6-1.fc9, compiz-0.7.6-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ccsm compizconfig-python compizconfig-backend-kconfig compiz-fusion-extras compizconfig-backend-gconf libcompizconfig compiz-fusion compiz'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5395

Comment 20 Fedora Update System 2008-06-22 20:44:53 UTC
ccsm-0.7.6-2.fc9, compizconfig-python-0.7.6-1.fc9, compizconfig-backend-kconfig-0.7.6-1.fc9, compiz-fusion-extras-0.7.6-1.fc9, compizconfig-backend-gconf-0.7.6-1.fc9, libcompizconfig-0.7.6-1.fc9, compiz-fusion-0.7.6-1.fc9, compiz-0.7.6-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.