Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230107 - OpenOffice.org2 menubars and button text doesn't display in encoding th_TH, th_TH.tis620 and th_TH.utf8
Summary: OpenOffice.org2 menubars and button text doesn't display in encoding th_TH, t...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openoffice.org
Version: 4.4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-26 17:52 UTC by Jan Lieskovsky
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-27 11:58:33 UTC


Attachments (Terms of Use)
scree (deleted)
2007-02-26 20:09 UTC, Caolan McNamara
no flags Details
screenshot (deleted)
2007-02-26 20:09 UTC, Caolan McNamara
no flags Details

Description Jan Lieskovsky 2007-02-26 17:52:58 UTC
Description of problem:
Set the locale to one of following: th_TH, th_TH.tis620 or th_TH.utf8, then
start some binary from the openoffice.org2 suite, oodraw2 for example.
You will see, that none of the menubars and button text is displayed.
(*.mo files for these encodings missing?)

Version-Release number of selected component (if applicable):
openoffice.org2-base-2.0.4-5.6.0.*

How reproducible:
Always

Steps to Reproduce:
1. set locale to one of th_TH, th_TH.tis620 or th_TH.utf8
2. start some ooffice2 binary (oocalc2 for example)
3. you will see, that text in menubars "File", "Open", "Edit" is blank
  (missing)
  
Actual results:
The button text is missing

Expected results:
Button text should be correctly displayed (in th_TH encoding, or at least
in English)

Additional info:
This bug is related with testing advisory of RHEA-2007:9031.

Comment 1 Caolan McNamara 2007-02-26 19:13:56 UTC
I'd be interested in knowing if the same is true for the RHEL-5 OOo which should
be about the same codebase as this.

Comment 2 Caolan McNamara 2007-02-26 20:09:43 UTC
Created attachment 148825 [details]
scree

Comment 3 Caolan McNamara 2007-02-26 20:09:50 UTC
Created attachment 148826 [details]
screenshot

Comment 4 Caolan McNamara 2007-02-26 20:13:14 UTC
Here's what it looks like for me. I think the problem is likely that you don't
have any thai fonts installed. Which is understandable as I don't think there
are any shipped with RHEL-4, though these are downloadable from
http://linux.thai.net/pub/thailinux/software/thai-ttf/

Comment 5 Caolan McNamara 2007-02-27 08:38:11 UTC
Can you confirm that adding the above fonts to your system, i.e.

# mkdir /usr/share/fonts/thai
# cp [fontfiles] /usr/share/fonts/thai
# fc-cache -f -v 

and then launching the thai OOo then shows content for the thai text ?

Comment 6 Jan Lieskovsky 2007-02-27 11:16:27 UTC
After following the above steps (after installing thai fonts:
. . .
fc-cache: "/usr/share/fonts/thai/TTF": caching, 27 fonts, 0 dirs
. . .)

OOo shows content for the thai text correctly too => NOT A BUG. 

Comment 7 Caolan McNamara 2007-02-27 11:58:33 UTC
excellent, all well.


Note You need to log in before you can comment on or make changes to this bug.