Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230074 - cups-lpd : server-args has no effect
Summary: cups-lpd : server-args has no effect
Keywords:
Status: CLOSED DUPLICATE of bug 230073
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups
Version: 5.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-26 14:31 UTC by Hans-Gerd van Schelve
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-26 15:19:11 UTC


Attachments (Terms of Use)
icds.convs (deleted)
2007-02-26 14:31 UTC, Hans-Gerd van Schelve
no flags Details

Description Hans-Gerd van Schelve 2007-02-26 14:31:14 UTC
We are sending icds compressed AFP (Advanced Function Presentation) Datastream
from our Z/OS System to mobile Linux Systems via lpd protocol. On the Linux
Systems based on rhel5-client-rc1 we have configured a server argument for
cups-lpd in /etc/xinetd.d/cups-lpd:

# default: off
# description: Allow applications using the legacy lpd protocol to communicate
with CUPS
service printer
{
        disable = no
        socket_type = stream
        protocol = tcp
        wait = no
        user = lp
        server = /usr/lib/cups/daemon/cups-lpd
        server_args = -o document-format=application/icds
}

We did this to enforce that everything that comes in via lpd has to pass our
cups filter icds2ps. Therefore we have two files /etc/cups/icds.types:

application/icds

and /etc/cups/icds.convs

application/icds        application/postscript  0       icds2ps

We have commented out application/octet-stream in /etc/cups/mime* :
/etc/cups/mime.convs:#application/octet-stream  application/vnd.cups-raw       
0       -
/etc/cups/mime.types:#application/octet-stream

The Problem now is, that the server_args argument seems to be ignored and
everything is passed to cups as application/octet-stream and not as
application/icds.

Comment 1 Hans-Gerd van Schelve 2007-02-26 14:31:14 UTC
Created attachment 148795 [details]
icds.convs

Comment 2 Tim Waugh 2007-02-26 15:19:11 UTC

*** This bug has been marked as a duplicate of 230073 ***


Note You need to log in before you can comment on or make changes to this bug.