Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230059 - rndis_host general protection fault on Nokia phone connection
Summary: rndis_host general protection fault on Nokia phone connection
Keywords:
Status: CLOSED DUPLICATE of bug 228231
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-26 12:25 UTC by John Depp
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-26 16:08:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Novell 206968 None None None Never

Description John Depp 2007-02-26 12:25:57 UTC
Description of problem:
kernel general protaction fault on loading of rndis_host module when connecting
Nokia phone

Version-Release number of selected component (if applicable):
kernel 2.6.19-1.2911.fc6 (unmodified)

Steps to Reproduce:
1. Connect Nokia 6151 phone by USB cable
2. Select "Standard" on phone as a type of connection

cdc_acm module loads perfectly while rndis_host gives an error:

GreenLinux kernel: general protection fault: 0000 [1] SMP 
Feb 26 13:52:05 GreenLinux kernel: drivers/usb/class/cdc-acm.c: Ignoring extra
header, type -3, length 4
Feb 26 13:52:05 GreenLinux kernel: cdc_acm 3-2:1.1: ttyACM0: USB ACM device
Feb 26 13:52:05 GreenLinux kernel: usbcore: registered new interface driver cdc_acm
Feb 26 13:52:05 GreenLinux kernel: drivers/usb/class/cdc-acm.c: v0.25:USB
Abstract Control Model driver for USB modems and ISDN adapters
Feb 26 13:52:05 GreenLinux kernel: usbcore: registered new interface driver
cdc_ether
Feb 26 13:52:05 GreenLinux kernel: rndis_host 3-2:1.9: RNDIS init failed, -110
Feb 26 13:52:05 GreenLinux kernel: usb%d: unregister 'rndis_host'
usb-0000:00:1d.2-2, RNDIS device
Feb 26 13:52:05 GreenLinux kernel: general protection fault: 0000 [1] SMP 
Feb 26 13:52:05 GreenLinux kernel: last sysfs file:
/devices/pci0000:00/0000:00:1d.2/usb3/3-2/3-2:1.12/bInterfaceProtocol
Feb 26 13:52:05 GreenLinux kernel: CPU 1 
Feb 26 13:52:05 GreenLinux kernel: Modules linked in: rndis_host cdc_ether
usbnet mii cdc_acm nls_utf8 ipv6 ppdev autofs4 vmnet(P)(U) vmmon(P)(U) vfat fat
dm_mirror dm_multipath dm_mod video sbs i2c_ec button battery asus_acpi ac lp
snd_hda_intel snd_hda_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq
snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm floppy snd_timer iTCO_wdt snd
ohci1394 sg soundcore nvidia(P)(U) pcspkr r8169 ieee1394 shpchp snd_page_alloc
i2c_i801 i2c_core parport_pc ide_cd parport cdrom serio_raw usb_storage ata_piix
libata sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd uhci_hcd
Feb 26 13:52:05 GreenLinux kernel: Pid: 3137, comm: modprobe Tainted: P     
2.6.19-1.2911.fc6 #1
Feb 26 13:52:05 GreenLinux kernel: RIP: 0010:[<ffffffff88b29090>] 
[<ffffffff88b29090>] :usbnet:usbnet_probe+0x28c/0x662
Feb 26 13:52:05 GreenLinux kernel: RSP: 0018:ffff810018243ca8  EFLAGS: 00010296
Feb 26 13:52:05 GreenLinux kernel: RAX: 3020302030203020 RBX: 00000000ffffff92
RCX: 0000000000000003
Feb 26 13:52:05 GreenLinux kernel: RDX: 000000000000001a RSI: 00000000fffffff4
RDI: ffff81001ed81000
Feb 26 13:52:05 GreenLinux kernel: RBP: ffff810020378648 R08: 0000000000000020
R09: 0000000000000000
Feb 26 13:52:05 GreenLinux kernel: R10: ffff81001b027730 R11: 0000000000000080
R12: ffff81001b7da580
Feb 26 13:52:05 GreenLinux kernel: R13: ffff81001b7da000 R14: ffff81001e7cbdc8
R15: 0000000000000018
Feb 26 13:52:05 GreenLinux kernel: FS:  00002aaaaaac7240(0000)
GS:ffff810037e21bc0(0000) knlGS:0000000000000000
Feb 26 13:52:05 GreenLinux kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Feb 26 13:52:05 GreenLinux kernel: CR2: 0000555555769e48 CR3: 0000000018269000
CR4: 00000000000006e0
Feb 26 13:52:05 GreenLinux kernel: Process modprobe (pid: 3137, threadinfo
ffff810018242000, task ffff81001877c0c0)
Feb 26 13:52:05 GreenLinux kernel: Stack:  ffff810018243d68 ffffffff80260f84
ffff810018243cf8 ffffffff8022e496
Feb 26 13:52:05 GreenLinux kernel:  0000000000000292 ffff81003c18f000
ffff81001e7cbc00 ffffffff88b367c0
Feb 26 13:52:05 GreenLinux kernel:  ffff81003b6a4800 000000921f66a713
0000000000008cb3 ffff81001e7cbc20
Feb 26 13:52:05 GreenLinux kernel: Call Trace:
Feb 26 13:52:05 GreenLinux kernel:  [<ffffffff803e0d4f>]
usb_probe_interface+0x7d/0xa4
Feb 26 13:52:05 GreenLinux kernel:  [<ffffffff803aecd9>] really_probe+0x4c/0xdf
Feb 26 13:52:05 GreenLinux kernel:  [<ffffffff803aef2b>] __driver_attach+0x90/0xcc
Feb 26 13:52:05 GreenLinux kernel:  [<ffffffff803ae287>] bus_for_each_dev+0x43/0x6e
Feb 26 13:52:05 GreenLinux kernel:  [<ffffffff803ae5cf>] bus_add_driver+0x6b/0x18d
Feb 26 13:52:05 GreenLinux kernel:  [<ffffffff803e0972>]
usb_register_driver+0x7e/0xe0
Feb 26 13:52:05 GreenLinux kernel:  [<ffffffff802a4981>]
sys_init_module+0x1728/0x18e3
Feb 26 13:52:05 GreenLinux kernel:  [<ffffffff8025c11e>] system_call+0x7e/0x83
Feb 26 13:52:05 GreenLinux kernel:  [<0000003c5d4cd96a>]
Feb 26 13:52:05 GreenLinux kernel: 
Feb 26 13:52:05 GreenLinux kernel: 
Feb 26 13:52:05 GreenLinux kernel: Code: f6 40 08 20 74 19 41 f6 85 a8 01 00 00
02 75 0f 48 c7 c6 1d 
Feb 26 13:52:05 GreenLinux kernel: RIP  [<ffffffff88b29090>]
:usbnet:usbnet_probe+0x28c/0x662
Feb 26 13:52:05 GreenLinux kernel:  RSP <ffff810018243ca8>

 
Additional info:
on Novel bugzilla bug is marked as "solved", btw only answer is "will be fixed
in 10.2 release"

Comment 1 Chuck Ebbert 2007-02-26 16:08:28 UTC

*** This bug has been marked as a duplicate of 228231 ***


Note You need to log in before you can comment on or make changes to this bug.