Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230047 - Lots of "4gb seg fixup" messages
Summary: Lots of "4gb seg fixup" messages
Keywords:
Status: CLOSED DUPLICATE of bug 215201
Alias: None
Product: Fedora
Classification: Fedora
Component: xen
Version: 6
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-26 10:03 UTC by k3dzngrp8w2xtc9
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-03 17:44:56 UTC


Attachments (Terms of Use)

Description k3dzngrp8w2xtc9 2007-02-26 10:03:38 UTC
Description of problem:
Lots of kernel messages like the following in Domain 0:
4gb seg fixup, process prelink (pid 23863), cs:ip 73:08084338
Not only for prelink but also gnome-screensaver, frysk, ...

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run Frysk on XenoLinux
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Berrange 2007-02-26 13:51:39 UTC
Not enough info. Please tell us kernel version, xen RPM version, glibc RPM
version. Also what files do you have in /etc/ld.so.conf.d/

Comment 2 k3dzngrp8w2xtc9 2007-02-27 08:09:33 UTC
All latest FC6:
kernel-xen-2.6.19-1.2911.fc6
xen-3.0.3-6.fc6
glibc-2.5-10.fc6

/etc/ld.so.conf.d/:
aplus-fsf-i386.conf               nvidia-glx.conf
kernelcap-2.6.19-1.2895.fc6.conf  qt-i386.conf
kernelcap-2.6.19-1.2911.fc6.conf

Xen mailing list suggests adding "hwcap 0 nosegneg" but it's already in
/etc/ld.so.conf.d/kernelcap-2.6.19-1.2911.fc6.conf

Comment 3 k3dzngrp8w2xtc9 2007-02-28 12:03:31 UTC
Maybe everything is "as designed". Prelink is statically linked to the wrong
glibc, so it naturally has this issue. Frysk is in Java which may not be
xen-friendly yet? Gnome-screensaver is a mystery...

Comment 4 Bernard Johnson 2007-03-03 17:44:56 UTC

*** This bug has been marked as a duplicate of 215201 ***


Note You need to log in before you can comment on or make changes to this bug.