Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230023 - Ugly message with default install
Summary: Ugly message with default install
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-26 00:15 UTC by Bastien Nocera
Modified: 2013-01-10 01:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-06-12 19:25:24 UTC


Attachments (Terms of Use)
Screenshot-xmessage.png (deleted)
2007-02-26 00:15 UTC, Bastien Nocera
no flags Details

Description Bastien Nocera 2007-02-26 00:15:53 UTC
htmlview-3.0.0-15.fc7

With rawhide from Friday 23rd Feb 2007.

zenity isn't installed by default, so I got this message when trying to start
the web browser, with Epiphany configured.

zenity should be required by htmlview, or at least be added to the comps.

Comment 1 Bastien Nocera 2007-02-26 00:15:53 UTC
Created attachment 148772 [details]
Screenshot-xmessage.png

Comment 2 Gilboa Davara 2007-04-10 05:31:18 UTC
Getting the same error under KDE.

$ htmlview
ERROR: The browser  does not exist.  Please reconfigure.

Then a dialog box:

"Failed to contact configuration server; some possible causes are that you 
need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to 
a system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)
Failed to contact configuration server; some possible causes are that you need 
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a 
system crash. See http://www.gnome.org/projects/gconf/ for information. 
(Details -  1: IOR file '/tmp/gconfd-gilboa/lock/ior' not opened successfully, 
no gconfd located: Permission denied 2: IOR file '/tmp/gconfd-gilboa/lock/ior' 
not opened successfully, no gconfd located: Permission denied)"

... In the mean time, in the console:

Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to allocate the agent. Exitting...
Failed to invoking the agent: No such file or directory
Cannot launch the agent
The messenger is now down
The messenger is now down
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to open the panel socket
Failed to allocate the agent. Exitting...
Failed to invoking the agent: No such file or directory
Cannot launch the agent
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()

And when I close the dialog box:

The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down
The messenger is now down

- Gilboa

Comment 3 Gilboa Davara 2007-04-10 05:32:51 UTC
... Forgot to add:

$ rpm -qa htmlview
htmlview-3.0.0-15.fc7.noarch

$ rpm -qa scim\*
scim-sinhala-0.2.0-2.fc6.x86_64
scim-bridge-gtk-0.4.10-1.fc7.x86_64
scim-libs-1.4.5-11.fc7.x86_64
scim-anthy-1.2.2-3.fc7.x86_64
scim-pinyin-0.5.91-16.fc7.x86_64
scim-libs-1.4.5-11.fc7.i386
scim-libs-1.4.5-12.fc7.i386
scim-hangul-0.3.1-1.fc7.x86_64
scim-bridge-0.4.10-1.fc7.x86_64
scim-tables-0.5.7-2.fc7.x86_64
scim-chewing-0.3.1-9.fc7.x86_64
scim-1.4.5-11.fc7.x86_64
scim-bridge-gtk-0.4.10-1.fc7.i386
scim-libs-1.4.5-12.fc7.x86_64
scim-m17n-0.2.1-1.fc7.x86_64


Comment 4 Gilboa Davara 2007-04-10 05:42:08 UTC
I'm getting the same error in gvim, evolution, firefox, etc:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=235782

Comment 5 Matthias Clasen 2007-04-10 09:45:41 UTC
htmlview looks like it was designed to not require zenity or gconf, but only use
them if they are available. Not sure if it is worth pulling zenity in the
default install. You can only ever get that error message if you uninstall a
previously selected browser, right ?

Comment 6 Rex Dieter 2007-04-10 18:18:19 UTC
imo, htmlview is/should-be pretty much deprecated by xdg-open

Comment 7 Bastien Nocera 2007-04-10 21:55:13 UTC
(In reply to comment #5)
> htmlview looks like it was designed to not require zenity or gconf, but only use
> them if they are available. Not sure if it is worth pulling zenity in the
> default install. You can only ever get that error message if you uninstall a
> previously selected browser, right ?

Yes, but it definitely looks untidy to use xmessage. Zenity itself uses a full
87kB on-disk, all the docs and extra pixmaps make it use ~2.2 megs in total.

Comment 8 Sebastian Vahl 2007-05-07 09:42:32 UTC
Any progress here? ATM a installation from kde livecd will also show this 
message.

Comment 9 Christopher Aillon 2007-05-07 13:02:09 UTC
Would rather this get done in comps.  I don't think adding the zenity
requirement is the right thing to do since it really is not required.

Comment 10 Warren Togami 2007-05-07 14:48:39 UTC
> imo, htmlview is/should-be pretty much deprecated by xdg-open

This is untrue.  xdg-open does not handle launching of the preferred application
without parameters.  gnome-open has the same failing too.

Comment 11 Jesse Keating 2007-05-07 15:34:29 UTC
I'm at a loss as to what needs to happen here.

Comment 12 Jesse Keating 2007-05-22 21:42:57 UTC
ping?  We're out of runway for Fedora 7...

Comment 13 Bastien Nocera 2007-05-22 22:25:32 UTC
I'd say you should just pull in zenity on the default install.

As for the error messages from bonobo-activation under KDE, I don't see how
they're related to the original bug report, and should have their own bug.

Comment 14 Jesse Keating 2007-06-12 19:25:24 UTC
I made Zenity the default for KDE and GNOME desktop groups.


Note You need to log in before you can comment on or make changes to this bug.