Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 230017 - "Can't listen on HID control channel: Address already in use" on startup
Summary: "Can't listen on HID control channel: Address already in use" on startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez-utils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact:
URL:
Whiteboard:
: 242591 247389 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-25 23:31 UTC by Bastien Nocera
Modified: 2007-11-30 22:11 UTC (History)
10 users (show)

Fixed In Version: 3.13-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-04 12:16:41 UTC


Attachments (Terms of Use)

Description Bastien Nocera 2007-02-25 23:31:37 UTC
bluez-utils-3.9-1.fc7

When starting hidd, I get the error:
Can't listen on HID control channel: Address already in use

I don't have any Bluetooth input devices configured, but a bluetooth adapter is
present. Stock rawhide install from the 23rd Feb 2007.

Comment 1 Frank Arnold 2007-05-18 11:15:14 UTC
I'm seeing this too with a clean rawhide install on PS3.

This problem somehow goes away with the following procedure:
1. Stop bluetooth service
2. Start hidd service
3. Start bluetooth service
4. Connect a device with `hidd --search` - PS3 BD Remote in my case

Comment 2 Marius Andreiana 2007-05-20 07:57:38 UTC
Confirming

Comment 3 Florian La Roche 2007-05-28 15:35:13 UTC
Still present with a stock F7 install, /etc/init.d/hidd is the only
service failing to start by default.

regards,

Florian La Roche


Comment 4 David Woodhouse 2007-07-21 10:51:19 UTC
*** Bug 247389 has been marked as a duplicate of this bug. ***

Comment 5 David Woodhouse 2007-07-21 10:54:36 UTC
*** Bug 242591 has been marked as a duplicate of this bug. ***

Comment 6 David Campbell 2007-07-31 07:57:18 UTC
I see the same thing in f7.

I was able to solve this by editing /etc/sysconfig/hidd and changing:
    HIDDARGS="--server"
to:
    HIDDARGS="-i hci0 --server"

Is this then an installer problem?


Comment 7 Bastien Nocera 2007-10-04 12:16:41 UTC
bluez-utils doesn't start hidd anymore in rawhide (since 3.13-1).


Note You need to log in before you can comment on or make changes to this bug.