Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2300 - rcp fails to report source-file-not-found
Summary: rcp fails to report source-file-not-found
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rsh
Version: 4.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL: ftp://ftp.mindspring.com/users/vallon...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-21 05:29 UTC by vallon
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-04 16:25:35 UTC


Attachments (Terms of Use)

Description vallon 1999-04-21 05:29:35 UTC
[Is this the right place for ppc.rpm bugs?]

Given host realhost and missing file no-file, "rcp no-file
realhost:." fails with a seg fault on ppc.

The problem is that the error function calls vfprintf
multiple times for a single va_start.  On ppc (at least),
vfprintf has side effects on va_list, and the second
vfprintf is no longer using the same args.

Reproducible on glibc-0.961212, MkLinux, rsh-0.10-2b.ppc.rpm
or rsh-0.10-24.ppc.rpm.

I'll submit a patch.  You should be able to find it at the
above URL.

------- Email Received From  Justin Vallon <vallon@mindspring.com> 04/21/99 01:44 -------

Comment 1 Jeff Johnson 1999-05-04 16:25:59 UTC
Fixed in rsh-0.10-26. Thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.