Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229996 - greek chars not displayed on startup
Summary: greek chars not displayed on startup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-02-25 17:12 UTC by Stephanos Manos
Modified: 2014-03-17 03:05 UTC (History)
3 users (show)

Fixed In Version: 8.52-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-13 22:30:38 UTC


Attachments (Terms of Use)
patch for this issue (deleted)
2007-04-13 22:30 UTC, Bill Nottingham
no flags Details | Diff

Description Stephanos Manos 2007-02-25 17:12:46 UTC
Description of problem:
if system lang is Greek when booting in text mode or shutting down the localized
text is displayed as boxes.

Version-Release number of selected component (if applicable):
initscripts-8.51-1

How reproducible:
always

Steps to Reproduce:
1.change system lang to greek
2.shutdown, restart in text mode
  
Actual results:
Localized text displayed as box

Expected results:
The text to be readable

Additional info:
The problem is the additional lines in lang.sh to fix BZ# 229102.
Removing these lines (the If $LANG ...) then works as expected.

Comment 1 Stephanos Manos 2007-03-29 19:13:30 UTC
ping ...

Comment 2 Simos Xenitellis 2007-03-30 01:01:37 UTC
I checked bug 229102 and did not notice a patch/etc. I could see a reference
with not sourcing /etc/sysconfig/i18n though it is not clear whether this is
system-wide or how it can be made to affect only SSH session.

Could you please provide a patch or show what needs to be changed so this bug 
can be fixed?

Comment 3 Stephanos Manos 2007-03-30 09:18:45 UTC
bug 229102 does not have a patch attached but as a result to fix it a If $LANG
... statement was added int he beginning of the the files /etc/profile.d/lang.sh
and /etc/profile.d/lang.csh

here is the beginning of the land.sh in f7
sourced=0

if [ -n "$LANG" ]; then
    sourced=1
else
    for langfile in /etc/sysconfig/i18n $HOME/.i18n ; do
    	[ -f $langfile ] && . $langfile && sourced=1
    done    
fi

and here is the line from fc6
sourced=0
for langfile in /etc/sysconfig/i18n $HOME/.i18n ; do
    [ -f $langfile ] && . $langfile && sourced=1
done  

if you remove the added if or more correctly(?) change it to 
if [ -n "$LANG" ]; then
    sourced=0
else
...

then the problem is solved

Comment 4 Dimitris Glezos 2007-04-04 13:53:47 UTC
Bill, any update on this?

Comment 5 Simos Xenitellis 2007-04-05 05:09:30 UTC
Stephanos, prepei na steileis patches (diff -u) gia ta dio arxeia, diaforetika
de 8a ginei tipota.

Comment 6 Bill Nottingham 2007-04-13 22:30:01 UTC
Created attachment 152595 [details]
patch for this issue

Try this - basically, we do need to re-read only when we're calling
unicode_start to set the font.

Comment 7 Bill Nottingham 2007-04-13 22:30:38 UTC
Will be in 8.52-1.

Comment 8 Dimitris Glezos 2007-04-14 00:08:51 UTC
Does this issue have anything in common with bug #222549?

Although this might not be the best place to ask this: do we have wiki pages
with instructions on how to convert such a patch to an SRPM and test it and info
about where these sources lie? (found out the CVS root of initscripts through
http://rhlinux.redhat.com/initscripts/, which I didn't know it existed until today.)

Comment 9 Bill Nottingham 2007-04-14 00:19:11 UTC
In as much as you also need to have SYSFONT set to something appropriate for
Greek, it's related. You can always set the font by hand, though.

As for the patch, you can add it as PatchN: just like in any other RPM.

Comment 10 Stephanos Manos 2007-04-15 16:10:15 UTC
(In reply to comment #9)
> In as much as you also need to have SYSFONT set to something appropriate for
> Greek, it's related. You can always set the font by hand, though.
Related only if you change language after installation.


As for the patch It works


Note You need to log in before you can comment on or make changes to this bug.