Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229978 - "Software Updater" icon is not themeable
Summary: "Software Updater" icon is not themeable
Keywords:
Status: CLOSED DUPLICATE of bug 208698
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-25 11:04 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-26 14:26:04 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2007-02-25 11:04:25 UTC
+++ This bug was initially created as a clone of Bug #208698 +++

Description of problem:
As of "pirut-1.2.1-1", an "Echo" style icon is used for the menu entry
"Software Updater" although "Bluecurve" is chosen as active icon theme
on my system.

Version-Release number of selected component (if applicable):
pirut-1.2.1-1

How reproducible:
Always

Steps to Reproduce:
1. Log in to "GNOME" session.
2. Open "Applications" -> "System Tools".
  
Actual results:
The "Software Updater" icon is part of the "Echo" icon set although
"Bluecurve" is the active icon theme, and the "Echo" them does not
even exist as part of "Fedora".

Expected results:
The "Software Updater" icon is part of the "Bluecurve" icon set
because "Bluecurve" is the active icon theme.

Additional info:
» A corresponding entry is found in the "pirut" changelog:
   '* Fri Sep 29 2006 Jeremy Katz <katzj@redhat.com> - 1.2.1-1'
   '- remember to include the new pup icon'
» A suitable icon does already exist in the "Blucurve" icon set,
  namely: "icon-update.png".

Desktop file "pup.desktop" specifies "pup.png" as icon to be used for
the "Software Updater" entry. This does not comply with the "Fedora"
naming scheme and breaks themeability. The correct entry would be
"icon-update.png", and the "new" icon needs to carry the same name and
be part of a (future) "Echo" theme for the menu icon to be themeable.

Comment 1 Joachim Frieben 2007-02-25 11:04:57 UTC
Issue still present in "pirut-1.2.8-1.fc6".

Comment 2 Jeremy Katz 2007-02-26 14:26:04 UTC
And you might also note that the bug is still open.  Cloning it just means that
I have to spend time looking and closing this report as a dupe instead of
spending that time on fixing things :-/

*** This bug has been marked as a duplicate of 208698 ***


Note You need to log in before you can comment on or make changes to this bug.