Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229968 - pata_via: different DMA for ident. disks on the same port
Summary: pata_via: different DMA for ident. disks on the same port
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-25 04:29 UTC by Ronald Warsow
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-21 15:50:57 UTC


Attachments (Terms of Use)

Description Ronald Warsow 2007-02-25 04:29:53 UTC
Description of problem:
i see different DMA's for 2 ident. disks on the same cable/ide-/ata- port

Version-Release number of selected component (if applicable):
2.6.20-1.2942.fc7

How reproducible:
(re-) boot

Steps to Reproduce:
1.
2.
3.
  
Actual results:
diff. dma

Expected results:
both disk with udma5

Additional info:
...
SCSI subsystem initialized
libata version 2.10 loaded.
pata_via 0000:00:0f.1: version 0.2.1
ACPI: PCI Interrupt 0000:00:0f.1[A] -> GSI 20 (level, low) -> IRQ 17
ata1: PATA max UDMA/133 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x0001fc00 irq 14
ata2: PATA max UDMA/133 cmd 0x00010170 ctl 0x00010376 bmdma 0x0001fc08 irq 15
scsi0 : pata_via
ata1.00: ATA-7: SAMSUNG SP0411N, TW100-11, max UDMA/100
ata1.00: 78242976 sectors, multi 16: LBA48 
ata1.01: ATA-7: SAMSUNG SP0411N, TW100-11, max UDMA/100
ata1.01: 78242976 sectors, multi 16: LBA48 
ata1.00: configured for UDMA/33
ata1.01: configured for UDMA/100


/dev/sda:

 Model=SAMSUNG SP0411N        , FwRev=TW100-11, SerialNo=S01JJ50Y167743      
...
 UDMA modes: udma0 udma1 *udma2 udma3 udma4 udma5 udma3 udma4 udma5 
...

/dev/sdb:

 Model=SAMSUNG SP0411N        , FwRev=TW100-11, SerialNo=S01JJ10Y268137      
...
 UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 udma3 udma4 *udma5 
...

hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads:   1178 MB in  2.00 seconds = 589.42 MB/sec
 Timing buffered disk reads:   84 MB in  3.06 seconds =  27.41 MB/sec

hdparm -tT /dev/sdb

/dev/sdb:
 Timing cached reads:   1148 MB in  2.00 seconds = 574.19 MB/sec
 Timing buffered disk reads:  152 MB in  3.02 seconds =  50.31 MB/sec

>:|

Comment 1 Alan Cox 2007-03-07 19:47:50 UTC
Known bug - cable detection problem - patch submitted upstream


Comment 2 Alan Cox 2007-03-21 15:50:57 UTC
Fixed upstream


Comment 3 Ronald Warsow 2007-06-02 09:38:39 UTC
to complete/extend this:

last the days a bought a new sata drive from samsung. this time in the box was a
description, turns out: SAMSUNG SP0411N drives are configured to run at 100
default. to run 133 you need to configure them via a software util. .


Note You need to log in before you can comment on or make changes to this bug.