Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229915 - fc6 driver issue reading CD Rom with intel motherboard DG965WH
Summary: fc6 driver issue reading CD Rom with intel motherboard DG965WH
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 6
Hardware: i686
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-24 09:37 UTC by Jeff Lacki
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-27 17:00:58 UTC


Attachments (Terms of Use)

Description Jeff Lacki 2007-02-24 09:37:30 UTC
Description of problem:

I got a new motherboard and cpu (Intel DG965WH w/Intel CPU Pentium D 820 
2.8Ghz dual core).
I took a working fed 6 HD and stuck it in and it wont boot, it 
complains during bootup saying: 


... 
Red Hat nash version 5.1.19.0.2 starting 
mount: could not find filesystem '/dev/root' 
setuproot: moving /dev failed: no such file or directory 
setuproot: error mounting /proc: no such file or directory 
setuproot: error mounting /sys: no such file or directory 
switchroot: mount failed: no such file or directory 
kernel panic - not syncing: attempted to kill init! 


then it freezes. 


I took same working disk and put it in my windows box (switching out 
the HD temporarily) and it boots and works just fine (its an older 
motherboard/cpu). 


next: 
I thought Id try to use the fedora 6 rescue disk and see if it might 
somehow 
correct itself (even though nothing seems to legitimately be wrong 
with it). 
Now it boots up the fedora rescue and I go through the menus.  Just 
after 
the language -> keyboard type -> I get to the menu that says: 


Rescue Method 


What type of media contains the rescue image? 
Local CDROM 
Hard Disk 
Floppy Drive 
FTP 
HTTP 


When I select CDROM (duh, I just boot from there), it says: 


unable to find any devices of the type 
needed for this install type. 
Would you like to manually select your 
driver or use a driver disk? 


OPTIONS: Select Driver    Use Driver Disk 

I have the latest BIOS from Intel on the board (I updated it
to be sure it wasnt a bios issue, version 1-17-2007 1618).
I believe its a supplied driver in the kernel?  However Im unsure.

If need more info, let me know.
I marked this urgent because I do need a solution ASAP to use this investment.
Thanks,
Jeff


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeremy Katz 2007-02-27 17:00:58 UTC
You're going to have to go into rescue mode, chroot into /mnt/sysimage, update
/etc/modprobe.conf and then re-run mkinitrd


Note You need to log in before you can comment on or make changes to this bug.