Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229893 - Autotools autoconf editor doesn't revert file when all changes backed out
Summary: Autotools autoconf editor doesn't revert file when all changes backed out
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-23 23:59 UTC by Jeff Johnston
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-24 00:05:00 UTC


Attachments (Terms of Use)

Description Jeff Johnston 2007-02-23 23:59:55 UTC
When the autoconf editor is used and Ctrl Z is used to back off all changes, the
file still appears with an asterisk and on close, the user is asked whether to
save changes or not.  This should not happen as all changes have been removed
from the file and it should be in original state.

Comment 1 Jeff Johnston 2007-02-24 00:05:00 UTC
The document provider used by the Autoconf editor does not properly support
undo.  The underlying document provider has been changed to a
TextFileDocumentProvider and the problem is fixed.  The fix will be part of an
0.0.8.1 update.


Note You need to log in before you can comment on or make changes to this bug.