Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229875 - unable to install Dell Optiplex 745 due to old ata_piix driver
Summary: unable to install Dell Optiplex 745 due to old ata_piix driver
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: David Milburn
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-23 22:09 UTC by Kathy Whyte
Modified: 2009-08-31 17:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-31 17:35:59 UTC


Attachments (Terms of Use)

Description Kathy Whyte 2007-02-23 22:09:19 UTC
Description of problem: System is undable to detect hardrives for system
installation.


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Begin system installation

  
Actual results: Anaconda installer reports: "An error has occured - no valid
devices were found on which to create new file systems. Please check your
hardare for the cause of this problem."

Expected results: Be able to install the system.


Additional info:
In order to get the machine to recognize the hard disk controller and attached
devices, the system needs a newer version of the ata_piix driver.

The unsupported HDD controller is an Intel ICH8 Serial ATA Storage Controller.
There are actually two chips, a 2 port and a 4 port controller, attached.
Both of which should be supported by a  new driver.

The vendor ID is 8086 and the device IDs are 2825 for the 2 port controller and
2820 for the 4 port controller.

Testing with a Kubuntu liveCD shows that at least of kernel version 2.6.20, this
chipset is supported, and the attached devices are recognized properly.

Please also respond to mwsv26@umr.edu as he is working with me on this issue.

Thanks,
Kathy Whyte
kaw@umr.edu

Comment 1 Jason Baron 2007-03-12 18:00:20 UTC
should be resolved in U5 with the update of ata_piix driver...

Comment 2 David Milburn 2009-08-31 17:35:59 UTC
Both devices 0x2820 and 0x2825 are defined in the RHEL4 U8 ata_piix driver.


Note You need to log in before you can comment on or make changes to this bug.