Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229844 - Unhandled exception in pup
Summary: Unhandled exception in pup
Keywords:
Status: CLOSED DUPLICATE of bug 229663
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-23 19:15 UTC by k3dzngrp8w2xtc9
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-23 20:05:52 UTC


Attachments (Terms of Use)

Description k3dzngrp8w2xtc9 2007-02-23 19:15:20 UTC
Description of problem:
Component: Software Updater
Summary: TBccefa5c9 yumRepo.py:426:__get:RepoError: failure:
repodata/updateinfo.xml.gz from updates: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 319, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 375, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 227, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 615, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 426, in __get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
RepoError: failure: repodata/updateinfo.xml.gz from updates: [Errno 256] No more
mirrors to try.

Local variables in innermost frame:
e: [Errno 256] No more mirrors to try.
start: None
url: None
text: None
self: updates
cache: True
reget: None
relative: repodata/updateinfo.xml.gz
headers: ()
checkfunc: (<bound method YumRepository.checkMD of <yum.yumRepo.YumRepository
object at 0x96e1bac>>, ('updateinfo',), {})
copy_local: 1
end: None
local: //var/cache/yum/updates/updateinfo.xml.gz


Version-Release number of selected component (if applicable):
FC6, 

How reproducible:
100%

Steps to Reproduce:
1. Run pup

Comment 1 Jeremy Katz 2007-02-23 20:05:52 UTC

*** This bug has been marked as a duplicate of 229663 ***


Note You need to log in before you can comment on or make changes to this bug.