Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229772 - SWI-Prolog requires GMP since version 5.6.0
Summary: SWI-Prolog requires GMP since version 5.6.0
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pl
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-23 12:53 UTC by Roberto Bagnara
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-23 17:09:30 UTC


Attachments (Terms of Use)

Description Roberto Bagnara 2007-02-23 12:53:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1

Description of problem:
Since version 5.6.0, SWI-Prolog supports unbounded integers thanks to GMP.  While it is true that SWI-Prolog works also without GMP, in which case it only offers small integers, the result is of strictly inferior quality (all serious Prolog systems provide unbounded integers).  The solution is to make sure that `pl' BuildRequires `gmp-devel': the SWI-Prolog configuration script will detect it and the right thing will happen.

While we are at it, we may want to upgrade to version 5.6.28.

I can submit a patch, if you want.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. pl


Actual Results:
?- current_prolog_flag(bounded, X).

X = true 

Yes


Expected Results:
?- current_prolog_flag(bounded, X).

X = false 

Yes


Additional info:

Comment 1 Gérard Milmeister 2007-02-23 17:09:30 UTC
Thanks for the notification.
The next build will also update to the newest version.


Note You need to log in before you can comment on or make changes to this bug.