Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229770 - Crashed every time (is this long enough?)
Summary: Crashed every time (is this long enough?)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: alacarte
Version: 6
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL: http://whatever
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-23 12:22 UTC by Terry Steichen
Modified: 2008-03-18 18:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-18 18:41:11 UTC


Attachments (Terms of Use)

Description Terry Steichen 2007-02-23 12:22:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070209 Fedora/1.5.0.9-3.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
Component: Software Updater
Summary: TBccefa5c9 yumRepo.py:426:__get:RepoError: failure: repodata/updateinfo.xml.gz from updates: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 319, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 375, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 227, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 615, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 426, in __get
    raise Errors.RepoError, "failure: %s from %s: %s" % (relative, self.id, e)
RepoError: failure: repodata/updateinfo.xml.gz from updates: [Errno 256] No more mirrors to try.

Local variables in innermost frame:
e: [Errno 256] No more mirrors to try.
start: None
url: None
text: None
self: updates
cache: True
reget: None
relative: repodata/updateinfo.xml.gz
headers: ()
checkfunc: (<bound method YumRepository.checkMD of <yum.yumRepo.YumRepository object at 0x94a2e8c>>, ('updateinfo',), {})
copy_local: 1
end: None
local: //var/cache/yum/updates/updateinfo.xml.gz


Version-Release number of selected component (if applicable):
see dump

How reproducible:
Always


Steps to Reproduce:
1.try to update
2.
3.

Actual Results:
got this dump

Expected Results:
update (dumb question for me)

Additional info:

Comment 1 Matthew Miller 2007-03-21 02:21:20 UTC
Moving to FC6 based on useragent string. You're not really running FC1, right?

Comment 2 Terry Steichen 2007-03-21 13:23:17 UTC
I am using FC6.  I think the problem is that the update script doesn't handle
the situation when the remote repository happens to be off-line.  Once that
repository was back up, I had no further failures.

Terry Steichen

Comment 3 Ray Strode [halfline] 2008-03-18 18:41:11 UTC
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)


Note You need to log in before you can comment on or make changes to this bug.