Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229738 - Printers gone after update
Summary: Printers gone after update
Keywords:
Status: CLOSED DUPLICATE of bug 230979
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-23 01:22 UTC by Rick Ellis
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-12 13:48:32 UTC


Attachments (Terms of Use)
cupsd.conf (deleted)
2007-03-09 17:32 UTC, Rick Ellis
no flags Details

Description Rick Ellis 2007-02-23 01:22:33 UTC
Description of problem:

Printing was working last week. After updates cups can no longer find a printer 
and trying to add a printer causes cups interface to hang forever.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim Waugh 2007-02-23 10:07:09 UTC
What does 'rpm -q cups' say?

Comment 2 Rick Ellis 2007-02-23 17:26:38 UTC
rpm -q cups
cups-1.2.7-1.8.fc6

Comment 3 Tim Waugh 2007-02-23 17:39:12 UTC
What do these commands say when you run them?:

grep ^cups-1 /var/log/rpmpkgs*
ls -ltr /var/log/rpmpkgs*

Comment 4 Rick Ellis 2007-02-23 17:42:35 UTC
grep ^cups-1 /var/log/rpmpkgs*
/var/log/rpmpkgs:cups-1.2.7-1.8.fc6.x86_64.rpm
/var/log/rpmpkgs.1:cups-1.2.7-1.8.fc6.x86_64.rpm
/var/log/rpmpkgs.2:cups-1.2.7-1.8.fc6.x86_64.rpm
/var/log/rpmpkgs.3:cups-1.2.7-1.7.fc6.x86_64.rpm
/var/log/rpmpkgs.4:cups-1.2.7-1.7.fc6.x86_64.rpm
[root@no2 php]# ls -ltr /var/log/rpmpkgs*
-rw-r--r-- 1 root root 56743 Jan 27 05:01 /var/log/rpmpkgs.4
-rw-r--r-- 1 root root 57114 Feb  3 04:58 /var/log/rpmpkgs.3
-rw-r--r-- 1 root root 57436 Feb 10 05:01 /var/log/rpmpkgs.2
-rw-r--r-- 1 root root 58836 Feb 17 04:59 /var/log/rpmpkgs.1
-rw-r--r-- 1 root root 59041 Feb 23 05:15 /var/log/rpmpkgs


Comment 5 Tim Waugh 2007-02-23 18:07:42 UTC
1. The cups package was last updated beween Feb 3rd and Feb 10th -- is it
possible that printing broke as long ago as the 10th?

2. What does this command say, when run as root?:

ls -ZR /etc/cups

Comment 6 Rick Ellis 2007-02-23 18:16:31 UTC
1:

I'm fairly sure I was able to print after that update.

2:

ls -ZR /etc/cups
/etc/cups:
-rw-------  root lp                                    classes.conf
-rw-------  root lp                                    classes.conf.O
-rw-r--r--  root lp                                    client.conf
-rw-r-----  root lp                                    cupsd.conf
-rw-r-----  root lp                                    cupsd.conf.default
-rw-r-----  root lp                                    cupsd.conf.O
drwxr-xr-x  root root system_u:object_r:cupsd_etc_t:s0 interfaces
-rw-r--r--  root root                                  lpoptions
-rw-r--r--  root root                                  mime.convs
-rw-r--r--  root root                                  mime.types
-rw-r--r--  root lp                                    pdftops.conf
drwxr-xr-x  root lp   system_u:object_r:cupsd_etc_t:s0 ppd
-rw-------  root lp                                    printers.conf
-rw-------  root lp                                    printers.conf.O
-rw-r--r--  root root                                  pstoraster.convs
-rw-r--r--  root lp                                    snmp.conf
drwx------  root lp   system_u:object_r:cupsd_etc_t:s0 ssl

/etc/cups/interfaces:

/etc/cups/ppd:

/etc/cups/ssl:


Comment 7 Tim Waugh 2007-03-09 14:15:10 UTC
Please attach /etc/cups/cupsd.conf.

Comment 8 Rick Ellis 2007-03-09 17:32:35 UTC
Created attachment 149712 [details]
cupsd.conf

Comment 9 Tim Waugh 2007-03-12 13:48:13 UTC
Found this in there:

ServerBin /usr/lib64/cups

So this is a duplicate.

Comment 10 Tim Waugh 2007-03-12 13:48:32 UTC

*** This bug has been marked as a duplicate of 230979 ***


Note You need to log in before you can comment on or make changes to this bug.