Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229737 - emacs fails to load
Summary: emacs fails to load
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ncurses
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-23 00:55 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-08 14:11:25 UTC


Attachments (Terms of Use)

Description Paul F. Johnson 2007-02-23 00:55:18 UTC
Description of problem:
emacs fails to load due to ncurses lib problem

Version-Release number of selected component (if applicable):
5.6-5.20070217.fc7

How reproducible:
Always

Steps to Reproduce:
1. Run emacs from the command line
2.
3.
  
Actual results:
Error comes back 

error while loading shared libraries: /usr/lib64/libncurses.so.5: file too short

Expected results:
emacs should start

Additional info:
Not tested under x86

Comment 1 Miroslav Lichvar 2007-02-23 10:05:54 UTC
This is related to bug #228891. Just remove /usr/lib*/libncurses.so.5 symlink,
and it should be ok.

This could be handled in a post script, but only upgrades from
ncurses-devel-5.5-25.20060715 and later are broken, I will see about that.

However, the emacs binary has RPATH /usr/lib64, that should be fixed.

Comment 2 Miroslav Lichvar 2007-03-08 14:11:25 UTC
Ok, the upgrade path won't be supported. Please remove the symlink manually.

Comment 3 Miroslav Lichvar 2007-08-17 10:54:11 UTC
*** Bug 253125 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.