Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229730 - Application modal dialogues
Summary: Application modal dialogues
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox
Version: 4.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
: ---
Assignee: Gecko Maintainer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-22 23:49 UTC by Bryan Mason
Modified: 2018-10-19 20:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-14 19:45:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 234819 None None None Never
Mozilla Foundation 319528 None None None Never

Description Bryan Mason 2007-02-22 23:49:11 UTC
+++ This bug was initially created as a clone of Bug #173992 +++

Launch Mozilla (or Firefox)
Ctrl-T a few times to open new tabs
Go to a different workspace
Open another Mozilla (or Firefox)
Press Ctrl-q (for Mozilla) or click the Quit menu item to quit that browser

The confirmation dialogue will popup on the first workspace, and the current
window will look dead. Mozilla/Firefox should be moved to the current desktop
along with its dialogue.

Comment 1 Bryan Mason 2007-02-23 00:00:40 UTC
Since you can't press Ctrl-Q in Firefox to close the browser, I've tried to
reproduce this problem by pressing Alt-F4 and selecting File->Quit on the menu.

The problem reproduces when you select File->Quit, but not by pressing Alt-F4. 
When you select File->Quit in the copy of Firefox running on the second
workspace, the modal dialog box appears in the first workspace, but when you
press Alt-F4, the dialog box appears in the second workspace.

Comment 2 Christopher Aillon 2007-04-09 16:21:50 UTC
This is an upstream issue that should be reported there.

Comment 7 RHEL Product and Program Management 2007-05-09 07:15:39 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.


Note You need to log in before you can comment on or make changes to this bug.