Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229725 - Yum 3.0.3 fails during transaction check on update or install
Summary: Yum 3.0.3 fails during transaction check on update or install
Keywords:
Status: CLOSED DUPLICATE of bug 229582
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-22 23:03 UTC by Stephen O. Gombosi
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-22 23:19:06 UTC


Attachments (Terms of Use)

Description Stephen O. Gombosi 2007-02-22 23:03:49 UTC
Description of problem:
Yum fails with the following error during transaction check on update or install:

[root@lap369 sog]# yum update kmod-fglrx
Loading "fastestmirror" plugin
Loading "kernel-module" plugin
Loading "fedorakmod" plugin
Loading "skip-broken" plugin
Loading "installonlyn" plugin
Loading "protectbase" plugin
Setting up Update Process
Setting up repositories
Determining fastest mirrors
Reading repository metadata in from local files
0 packages excluded due to repository protections
Resolving Dependencies
/usr/lib/yum-plugins/kernel-module.py:61: DeprecationWarning: getHdrList() will
go away in a future version of Yum.

  for hdr in conduit.getRpmDB().getHdrList():
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kmod-fglrx to pack into transaction set.
kmod-fglrx-8.33.6-1.2.6.1 100% |=========================|  13 kB    00:00     
---> Package kmod-fglrx.i686 0:8.33.6-1.2.6.19_1.2911.fc6 set to be installed
--> Running transaction check
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fedorakmod.py", line 273, in postresolve_hook
    newKernels + installedKernels)
  File "/usr/lib/yum-plugins/fedorakmod.py", line 228, in installAllKmods
    table = resolveVersions(interesting + modules)
  File "/usr/lib/yum-plugins/fedorakmod.py", line 152, in resolveVersions
    elif sameName == None:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
    if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name
== other.name:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35, in comparePoEVR
    (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
AttributeError: 'NoneType' object has no attribute 'epoch'


Version-Release number of selected component (if applicable):
3.0.3

How reproducible:

100% reproducible
Steps to Reproduce:
1.Do "yum update package-name" or "yum install package-name"
2.
3.
  
Actual results:
Yum aborts during transaction check (before actually downloading packages)

Expected results:
Packages downloaded and installed

Additional info:

Problem began immediately upon updating yum to 3.0.3 yesterday

Comment 1 Stephen O. Gombosi 2007-02-22 23:19:06 UTC

*** This bug has been marked as a duplicate of 229582 ***


Note You need to log in before you can comment on or make changes to this bug.