Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 229718 - ACPI does not see when the AC is plugged or unplugged
Summary: ACPI does not see when the AC is plugged or unplugged
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-22 22:16 UTC by Aurelien Bompard
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-25 16:01:29 UTC


Attachments (Terms of Use)

Description Aurelien Bompard 2007-02-22 22:16:12 UTC
Description of problem:
This is on a HP laptop running FC7test1 with latest updates.
When the AC is plugged or unplugged, the gnome applet does not change, and both
acpi and acpitool do not see the change.
I know the problem does not come from the hardware because there is a Mandriva
2007 in dual-boot on this laptop, which properly sees the changes.


Version-Release number of selected component (if applicable):
kernel-2.6.20-1.2936.fc7 (same problem with 2932 or 2.6.19-1.2914)

How reproducible:
Always


Steps to Reproduce:
1. Plug the AC cord. Nothing reports it as plugged in. 
2. Reboot. Is it now seen as plugged.
3. Unplug it. All tools report it as still plugged in
  
Additional info:
Please ask if you need any information, like the output of dmesg or dmidecode or
anything else.

Comment 1 Aurelien Bompard 2007-02-23 21:29:04 UTC
Actually, it is not always reproductible : it works sometimes.
I'll investigate further, but it looks like the problem occurs after I try to
suspend or hibernate the laptop (both fail and I have to hard reboot)

Comment 2 Aurelien Bompard 2007-02-25 16:01:29 UTC
I can't reproduce it with 2.6.20-1.2942, I'll reopen the bug if it happens again

Comment 3 Bill Nottingham 2007-03-02 17:44:58 UTC
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.


Note You need to log in before you can comment on or make changes to this bug.